jack-audio-connection-kit.SlackBuild 4.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131
  1. #!/bin/sh
  2. # Slackware build script for jack-audio-connection-kit
  3. # Copyright 2007-2014 Heinz Wiesinger, Amsterdam, The Netherlands
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. # Modified by Robby Workman <rworkman@slackbuilds.org>
  23. # No additional license terms added :)
  24. # Modified and now maintained by B. Watson <yalhcru@gmail.com>
  25. PRGNAM=jack-audio-connection-kit
  26. VERSION=${VERSION:-0.125.0}
  27. BUILD=${BUILD:-1}
  28. TAG=${TAG:-_SBo}
  29. if [ -z "$ARCH" ]; then
  30. case "$( uname -m )" in
  31. i?86) ARCH=i586 ;;
  32. arm*) ARCH=arm ;;
  33. *) ARCH=$( uname -m ) ;;
  34. esac
  35. fi
  36. CWD=$(pwd)
  37. TMP=${TMP:-/tmp/SBo}
  38. PKG=$TMP/package-$PRGNAM
  39. OUTPUT=${OUTPUT:-/tmp}
  40. if [ "$ARCH" = "i586" ]; then
  41. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  42. LIBDIRSUFFIX=""
  43. elif [ "$ARCH" = "i686" ]; then
  44. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  45. LIBDIRSUFFIX=""
  46. elif [ "$ARCH" = "x86_64" ]; then
  47. SLKCFLAGS="-O2 -fPIC"
  48. LIBDIRSUFFIX="64"
  49. else
  50. SLKCFLAGS="-O2"
  51. LIBDIRSUFFIX=""
  52. fi
  53. set -e
  54. rm -rf $PKG
  55. mkdir -p $TMP $PKG $OUTPUT
  56. cd $TMP
  57. rm -rf $PRGNAM-$VERSION
  58. tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
  59. cd $PRGNAM-$VERSION
  60. chown -R root:root .
  61. find -L . \
  62. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
  63. -exec chmod 755 {} \+ -o \
  64. \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
  65. -exec chmod 644 {} \+
  66. # respect march and mtune flags: fixes building on x86_64
  67. sed -i 's|-march=native \-mtune=native||' configure.ac
  68. autoreconf -fi
  69. CFLAGS="$SLKCFLAGS" \
  70. CXXFLAGS="$SLKCFLAGS" \
  71. LDFLAGS="-L/usr/lib${LIBDIRSUFFIX}" \
  72. ./configure \
  73. --prefix=/usr \
  74. --libdir=/usr/lib${LIBDIRSUFFIX} \
  75. --sysconfdir=/etc \
  76. --localstatedir=/var \
  77. --with-html-dir=/usr/doc/$PRGNAM-$VERSION \
  78. --mandir=/usr/man \
  79. --enable-optimize \
  80. --with-default-tmpdir=/dev/shm \
  81. --build=$ARCH-slackware-linux \
  82. --host=$ARCH-slackware-linux
  83. make
  84. make install-strip DESTDIR=$PKG
  85. gzip -9 $PKG/usr/man/man?/*.?
  86. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  87. cp -a AUTHORS COPYING* README TODO $PKG/usr/doc/$PRGNAM-$VERSION
  88. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  89. cat $CWD/loop2jack.example > $PKG/usr/doc/$PRGNAM-$VERSION/loop2jack.example
  90. cat $CWD/asound.conf.jack-audio > $PKG/usr/doc/$PRGNAM-$VERSION/asound.conf.example
  91. cat $CWD/asound.conf.jack-audio > $PKG/usr/doc/$PRGNAM-$VERSION/asoundrc.example
  92. mkdir -p $PKG/install
  93. cat $CWD/slack-desc > $PKG/install/slack-desc
  94. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  95. mkdir -p $PKG/etc
  96. mkdir -p $PKG/etc/modprobe.d
  97. mkdir -p $PKG/usr/local/bin
  98. cat $CWD/asound.conf.jack-audio > $PKG/etc/asound.conf.jack-audio
  99. cat $CWD/initscript > $PKG/etc/initscript
  100. cat $CWD/alsaloop.conf > $PKG/alsaloop.conf
  101. cat $CWD/loop2jack > $PKG/usr/local/bin/loop2jack
  102. cat $CWD/alsaloop.conf > $PKG/etc/modprobe.d/alsaloop.conf
  103. # Only add capability stuff if not disabled:
  104. if [ "${SETCAP:-yes}" = "yes" ]; then
  105. cat $CWD/setcap.sh >> $PKG/install/doinst.sh
  106. # Only allow execution by audio group
  107. chown root:audio $PKG/usr/bin/*
  108. chmod 0750 $PKG/usr/bin/*
  109. fi
  110. cd $PKG
  111. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}