hardware-configuration.nix 767 B

123456789101112131415161718192021222324252627
  1. # Do not modify this file! It was generated by ‘nixos-generate-config’
  2. # and may be overwritten by future invocations. Please make changes
  3. # to /etc/nixos/configuration.nix instead.
  4. { config, lib, pkgs, ... }:
  5. {
  6. imports =
  7. [ <nixpkgs/nixos/modules/installer/scan/not-detected.nix>
  8. ];
  9. boot.initrd.availableKernelModules = [ "uhci_hcd" "ehci_pci" "ahci" "usb_storage" "sd_mod" ];
  10. boot.initrd.kernelModules = [ ];
  11. boot.kernelModules = [ "kvm-intel" ];
  12. boot.extraModulePackages = [ ];
  13. fileSystems."/" =
  14. { device = "/dev/disk/by-uuid/39b4cd24-91eb-4dbb-8509-c377c3750cc0";
  15. fsType = "ext4";
  16. };
  17. swapDevices =
  18. [ { device = "/dev/disk/by-uuid/e630f178-40aa-477c-9497-d0874d7c8ffe"; }
  19. ];
  20. nix.maxJobs = lib.mkDefault 2;
  21. }