perl-extra-packages.org 2.3 KB

this code works

;; ;;; Jmacs is free software; you can redistribute it and/or modify it ;; ;;; under the terms of the GNU General Public License as published by ;; ;;; the Free Software Foundation; either version 3 of the License, or (at ;; ;;; your option) any later version. ;; ;;; ;; ;;; Jmacs is distributed in the hope that it will be useful, but ;; ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;; ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;; ;;; GNU General Public License for more details. ;; ;;; ;; ;;; You should have received a copy of the GNU General Public License ;; ;;; along with Jmacs. If not, see .

;; ;; This is my specific customization of Emacs ;; ;; It loads in some specific emacs packages, and adds those as propogated ;; ;; inputs to my emacs

;; (define-module (gnu packages perl-extra-packages) ;; #:use-module (srfi srfi-1) ;; #:use-module (guix licenses) ;; #:use-module (gnu packages) ;; #:use-module (gnu packages perl) ;; #:use-module (guix packages) ;; #:use-module (guix download) ;; #:use-module (guix utils) ;; #:use-module (guix build-system gnu) ;; #:use-module (guix build-system perl) ;; #:use-module (gnu packages base) ;; #:use-module (gnu packages compression) ;; #:use-module (gnu packages freedesktop) ;; #:use-module (gnu packages less) ;; #:use-module (gnu packages ncurses) ;; #:use-module (gnu packages perl-check) ;; #:use-module (gnu packages perl-compression) ;; #:use-module (gnu packages perl-web) ;; #:use-module (gnu packages pkg-config) ;; #:use-module (gnu packages readline) ;; #:use-module (gnu packages textutils))

;; (define-public perl-yaml-syck ;; (package ;; (name "perl-yaml-syck") ;; (version "1.32") ;; (source ;; (origin ;; (method url-fetch) ;; (uri (string-append ;; "mirror://cpan/authors/id/T/TO/TODDR/YAML-Syck-" ;; version ;; ".tar.gz")) ;; (sha256 ;; (base32 ;; "1fz9r9vvsmjkzvcbznxw65b319vkmwzd0ck09q9nwip00gn907fv")))) ;; (build-system perl-build-system) ;; (home-page ;; "https://metacpan.org/release/YAML-Syck") ;; (synopsis ;; "Fast, lightweight YAML loader and dumper") ;; (description "This is a tiny package that the Hurd wiki uses.") ;; (license x11)))