0007-vdec-fix-MPEG-4-codec-data-aspect-ratio-parsing.patch 977 B

123456789101112131415161718192021222324252627282930
  1. From 13cc06462e0b40bd246abd8a2509a8434f18c3a9 Mon Sep 17 00:00:00 2001
  2. From: Mark Nauwelaerts <mark.nauwelaerts@collabora.co.uk>
  3. Date: Mon, 7 Sep 2009 18:53:24 +0200
  4. Subject: [PATCH] vdec: fix MPEG-4 codec data aspect ratio parsing
  5. Signed-off-by: Mark Nauwelaerts <mark.nauwelaerts@collabora.co.uk>
  6. ---
  7. gstdspparse.c | 6 +++---
  8. 1 files changed, 3 insertions(+), 3 deletions(-)
  9. diff --git a/gstdspparse.c b/gstdspparse.c
  10. index e42c27d..2722923 100644
  11. --- a/gstdspparse.c
  12. +++ b/gstdspparse.c
  13. @@ -567,11 +567,11 @@ gst_dsp_mpeg4_parse(GstDspBase* base, GstBuffer *buf)
  14. goto failed;
  15. /* check if aspect ratio info is extended par */
  16. - if (bits == 0xff) {
  17. + if (bits == 0xf) {
  18. /* aspect_ratio_width */
  19. - GET_BITS (&bs, 4, &bits);
  20. + GET_BITS (&bs, 8, &bits);
  21. /* aspect_ratio_height */
  22. - GET_BITS (&bs, 4, &bits);
  23. + GET_BITS (&bs, 8, &bits);
  24. } else if (bits < 0x6) {
  25. /* get aspect ratio width and height from aspect ratio table */
  26. }