123456789101112131415161718192021222324252627282930 |
- From 13cc06462e0b40bd246abd8a2509a8434f18c3a9 Mon Sep 17 00:00:00 2001
- From: Mark Nauwelaerts <mark.nauwelaerts@collabora.co.uk>
- Date: Mon, 7 Sep 2009 18:53:24 +0200
- Subject: [PATCH] vdec: fix MPEG-4 codec data aspect ratio parsing
- Signed-off-by: Mark Nauwelaerts <mark.nauwelaerts@collabora.co.uk>
- ---
- gstdspparse.c | 6 +++---
- 1 files changed, 3 insertions(+), 3 deletions(-)
- diff --git a/gstdspparse.c b/gstdspparse.c
- index e42c27d..2722923 100644
- --- a/gstdspparse.c
- +++ b/gstdspparse.c
- @@ -567,11 +567,11 @@ gst_dsp_mpeg4_parse(GstDspBase* base, GstBuffer *buf)
- goto failed;
-
- /* check if aspect ratio info is extended par */
- - if (bits == 0xff) {
- + if (bits == 0xf) {
- /* aspect_ratio_width */
- - GET_BITS (&bs, 4, &bits);
- + GET_BITS (&bs, 8, &bits);
- /* aspect_ratio_height */
- - GET_BITS (&bs, 4, &bits);
- + GET_BITS (&bs, 8, &bits);
- } else if (bits < 0x6) {
- /* get aspect ratio width and height from aspect ratio table */
- }
|