0005-hack-base-don-t-return-state-change-errors.patch 1.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051
  1. From 8df0af578a9982e0492afe52730ddca2485caeee Mon Sep 17 00:00:00 2001
  2. From: Felipe Contreras <felipe.contreras@nokia.com>
  3. Date: Thu, 13 Aug 2009 19:52:45 +0300
  4. Subject: [PATCH] hack: base: don't return state change errors
  5. Otherwise playbin will try to use the next available element, and we
  6. don't want that in Maemo right now because gst-openmax is still around.
  7. Signed-off-by: Felipe Contreras <felipe.contreras@nokia.com>
  8. ---
  9. gstdspbase.c | 12 +++---------
  10. 1 files changed, 3 insertions(+), 9 deletions(-)
  11. diff --git a/gstdspbase.c b/gstdspbase.c
  12. index de66763..e43d86e 100644
  13. --- a/gstdspbase.c
  14. +++ b/gstdspbase.c
  15. @@ -800,10 +800,8 @@ change_state(GstElement *element,
  16. switch (transition) {
  17. case GST_STATE_CHANGE_NULL_TO_READY:
  18. - if (!dsp_init(self)) {
  19. + if (!dsp_init(self))
  20. gstdsp_post_error(self, "dsp init failed");
  21. - return GST_STATE_CHANGE_FAILURE;
  22. - }
  23. break;
  24. case GST_STATE_CHANGE_READY_TO_PAUSED:
  25. @@ -832,18 +830,14 @@ change_state(GstElement *element,
  26. switch (transition) {
  27. case GST_STATE_CHANGE_PAUSED_TO_READY:
  28. - if (!dsp_stop(self)) {
  29. + if (!dsp_stop(self))
  30. gstdsp_post_error(self, "dsp stop failed");
  31. - return GST_STATE_CHANGE_FAILURE;
  32. - }
  33. break;
  34. case GST_STATE_CHANGE_READY_TO_NULL:
  35. gst_caps_replace(&self->tmp_caps, NULL);
  36. - if (!dsp_deinit(self)) {
  37. + if (!dsp_deinit(self))
  38. gstdsp_post_error(self, "dsp deinit failed");
  39. - return GST_STATE_CHANGE_FAILURE;
  40. - }
  41. break;
  42. default: