123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051 |
- From 8df0af578a9982e0492afe52730ddca2485caeee Mon Sep 17 00:00:00 2001
- From: Felipe Contreras <felipe.contreras@nokia.com>
- Date: Thu, 13 Aug 2009 19:52:45 +0300
- Subject: [PATCH] hack: base: don't return state change errors
- Otherwise playbin will try to use the next available element, and we
- don't want that in Maemo right now because gst-openmax is still around.
- Signed-off-by: Felipe Contreras <felipe.contreras@nokia.com>
- ---
- gstdspbase.c | 12 +++---------
- 1 files changed, 3 insertions(+), 9 deletions(-)
- diff --git a/gstdspbase.c b/gstdspbase.c
- index de66763..e43d86e 100644
- --- a/gstdspbase.c
- +++ b/gstdspbase.c
- @@ -800,10 +800,8 @@ change_state(GstElement *element,
-
- switch (transition) {
- case GST_STATE_CHANGE_NULL_TO_READY:
- - if (!dsp_init(self)) {
- + if (!dsp_init(self))
- gstdsp_post_error(self, "dsp init failed");
- - return GST_STATE_CHANGE_FAILURE;
- - }
- break;
-
- case GST_STATE_CHANGE_READY_TO_PAUSED:
- @@ -832,18 +830,14 @@ change_state(GstElement *element,
-
- switch (transition) {
- case GST_STATE_CHANGE_PAUSED_TO_READY:
- - if (!dsp_stop(self)) {
- + if (!dsp_stop(self))
- gstdsp_post_error(self, "dsp stop failed");
- - return GST_STATE_CHANGE_FAILURE;
- - }
- break;
-
- case GST_STATE_CHANGE_READY_TO_NULL:
- gst_caps_replace(&self->tmp_caps, NULL);
- - if (!dsp_deinit(self)) {
- + if (!dsp_deinit(self))
- gstdsp_post_error(self, "dsp deinit failed");
- - return GST_STATE_CHANGE_FAILURE;
- - }
- break;
-
- default:
|