01_default-config.dpatch 6.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215
  1. #!/bin/sh -e
  2. ## 01_default-config.dpatch (originally) by Adrian Bunk <bunk@fs.tum.de>
  3. ##
  4. ## All lines beginning with `## DP:' are a description of the patch.
  5. ## DP: Fix the default config for Debian.
  6. if [ $# -lt 1 ]; then
  7. echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
  8. exit 1
  9. fi
  10. [ -f debian/patches/00patch-opts ] && . debian/patches/00patch-opts
  11. patch_opts="${patch_opts:--f --no-backup-if-mismatch}"
  12. case "$1" in
  13. -patch) patch $patch_opts -p1 < $0;;
  14. -unpatch) patch $patch_opts -p1 -R < $0;;
  15. *)
  16. echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
  17. exit 1;;
  18. esac
  19. exit 0
  20. @DPATCH@
  21. diff -urNad lynx-2.8.6~/lynx.cfg lynx-2.8.6/lynx.cfg
  22. --- lynx-2.8.6~/lynx.cfg 2006-09-18 20:28:28.000000000 -0400
  23. +++ lynx-2.8.6/lynx.cfg 2007-05-25 09:31:42.000000000 -0400
  24. @@ -92,7 +92,7 @@
  25. #
  26. # Normally we expect you will connect to a remote site, e.g., the Lynx starting
  27. # site:
  28. -STARTFILE:http://lynx.isc.org/
  29. +STARTFILE:file:///usr/share/ubuntu-artwork/home/index.html
  30. #
  31. # As an alternative, you may want to use a local URL. A good choice for this is
  32. # the user's home directory:
  33. @@ -115,7 +115,7 @@
  34. # http://www.subir.com/lynx/lynx_help/lynx_help_main.html
  35. # This should be changed to the local path.
  36. #
  37. -HELPFILE:http://www.subir.com/lynx/lynx_help/lynx_help_main.html
  38. +HELPFILE:file://localhost/usr/share/doc/lynx/lynx_help/lynx_help_main.html
  39. .ex
  40. #HELPFILE:file://localhost/PATH_TO/lynx_help/lynx_help_main.html
  41. @@ -492,7 +492,7 @@
  42. # compatibility problems with other browsers, see also PREPEND_BASE_TO_SOURCE.
  43. # Note that the prepending is not done for -source dumps.
  44. #
  45. -#PREPEND_CHARSET_TO_SOURCE:TRUE
  46. +PREPEND_CHARSET_TO_SOURCE:FALSE
  47. .h2 NCR_IN_BOOKMARKS
  48. @@ -935,8 +935,8 @@
  49. # executed. This is much less dangerous than enabling all execution
  50. # links, but can still be dangerous.
  51. #
  52. -#LOCAL_EXECUTION_LINKS_ALWAYS_ON:FALSE
  53. -#LOCAL_EXECUTION_LINKS_ON_BUT_NOT_REMOTE:FALSE
  54. +LOCAL_EXECUTION_LINKS_ALWAYS_ON:FALSE
  55. +LOCAL_EXECUTION_LINKS_ON_BUT_NOT_REMOTE:FALSE
  56. .h2 TRUSTED_EXEC
  57. @@ -984,7 +984,7 @@
  58. # as well (i.e., they will only be able to access lynxexec or lynxprog
  59. # URLs which meet any ALWAYS_TRUSTED_EXEC rules).
  60. #
  61. -#TRUSTED_EXEC:none
  62. +TRUSTED_EXEC:none
  63. .h2 ALWAYS_TRUSTED_EXEC
  64. @@ -1006,7 +1006,7 @@
  65. #
  66. # The default ALWAYS_TRUSTED_EXEC rule is "none".
  67. #
  68. -#ALWAYS_TRUSTED_EXEC:none
  69. +ALWAYS_TRUSTED_EXEC:none
  70. .h2 TRUSTED_LYNXCGI
  71. @@ -1026,7 +1026,7 @@
  72. # ====
  73. # Do not define this.
  74. #
  75. -#TRUSTED_LYNXCGI:none
  76. +TRUSTED_LYNXCGI:none
  77. .h2 LYNXCGI_ENVIRONMENT
  78. @@ -1123,7 +1123,7 @@
  79. # The news reading facility in Lynx is quite limited. Lynx does not provide a
  80. # full featured news reader with elaborate error checking and safety features.
  81. #
  82. -#NNTPSERVER:news.server.dom
  83. +NNTPSERVER:news
  84. .h2 LIST_NEWS_NUMBERS
  85. @@ -1597,7 +1597,7 @@
  86. # unless you know EVERY user will know how to use it;
  87. # users can easily define their own editor in the Options Menu.
  88. #
  89. -#DEFAULT_EDITOR:
  90. +DEFAULT_EDITOR: /usr/bin/sensible-editor
  91. .h2 SYSTEM_EDITOR
  92. @@ -1788,7 +1788,7 @@
  93. # and not forced TRUE, the user can regulate it via the 'o'ptions menu (and
  94. # may save the preference in the RC file).
  95. #
  96. -#NO_DOT_FILES:TRUE
  97. +NO_DOT_FILES:TRUE
  98. .h1 Internal Behavior
  99. @@ -2035,7 +2035,7 @@
  100. # the command line, and the latter switch overrides the setting of the
  101. # PREPEND_BASE_TO_SOURCE configuration variable.
  102. #
  103. -#PREPEND_BASE_TO_SOURCE:TRUE
  104. +PREPEND_BASE_TO_SOURCE:FALSE
  105. # MIME types and viewers!
  106. @@ -2071,13 +2071,13 @@
  107. #
  108. # Unix:
  109. # ====
  110. -#GLOBAL_EXTENSION_MAP:/usr/local/lib/mosaic/mime.types
  111. +GLOBAL_EXTENSION_MAP:/etc/mime.types
  112. # VMS:
  113. # ===
  114. #GLOBAL_EXTENSION_MAP:Lynx_Dir:mime.types
  115. #
  116. # Unix (sought in user's home directory):
  117. -#PERSONAL_EXTENSION_MAP:.mime.types
  118. +PERSONAL_EXTENSION_MAP:.mime.types
  119. # VMS (sought in user's sys$login directory):
  120. #PERSONAL_EXTENSION_MAP:mime.types
  121. @@ -2253,7 +2253,7 @@
  122. # XLOADIMAGE_COMMAND definition.
  123. # If you use xli, you may want to add the -quiet flag.
  124. #
  125. -#XLOADIMAGE_COMMAND:xli %s &
  126. +XLOADIMAGE_COMMAND:
  127. .h2 VIEWER
  128. # MIME types may be assigned to external viewers using
  129. @@ -2317,7 +2317,7 @@
  130. #
  131. # Unix:
  132. # ====
  133. -#GLOBAL_MAILCAP:/usr/local/lib/mosaic/mailcap
  134. +GLOBAL_MAILCAP:/etc/mailcap
  135. # VMS:
  136. # ===
  137. #GLOBAL_MAILCAP:Lynx_Dir:mailcap
  138. @@ -2926,9 +2926,8 @@
  139. # blue magenta cyan lightgray
  140. # gray brightred brightgreen yellow
  141. # brightblue brightmagenta brightcyan white
  142. +# default
  143. .fi
  144. -# or (if you have configured using --enable-default-colors with ncurses or
  145. -# slang), "default" may be used for foreground and background.
  146. #
  147. # Note that in most cases a white background is really "lightgray", since
  148. # terminals generally do not implement bright backgrounds.
  149. @@ -2941,8 +2940,7 @@
  150. #COLOR:3:green:white
  151. #COLOR:4:magenta:white
  152. #COLOR:5:blue:white
  153. -#COLOR:6:red:white
  154. -COLOR:6:brightred:black
  155. +#COLOR:6:brightred:black
  156. #COLOR:7:magenta:cyan
  157. diff -urNad lynx-2.8.6~/userdefs.h lynx-2.8.6/userdefs.h
  158. --- lynx-2.8.6~/userdefs.h 2004-12-30 07:11:59.000000000 -0500
  159. +++ lynx-2.8.6/userdefs.h 2007-05-25 09:29:52.000000000 -0400
  160. @@ -296,7 +296,7 @@
  161. * Mappings in these global and personal files override any SUFFIX
  162. * definitions in lynx.cfg and built-in defaults from src/HTInit.c.
  163. */
  164. -#define GLOBAL_EXTENSION_MAP "/usr/local/lib/mosaic/mime.types"
  165. +#define GLOBAL_EXTENSION_MAP "/etc/mime.types"
  166. #define PERSONAL_EXTENSION_MAP ".mime.types"
  167. /**************************
  168. @@ -306,7 +306,7 @@
  169. * Mappings in these global and personal files override any VIEWER
  170. * definitions in lynx.cfg and built-in defaults from src/HTInit.c.
  171. */
  172. -#define GLOBAL_MAILCAP "/usr/local/lib/mosaic/mailcap"
  173. +#define GLOBAL_MAILCAP "/etc/mailcap"
  174. #define PERSONAL_MAILCAP ".mailcap"
  175. /**************************
  176. @@ -324,7 +324,7 @@
  177. * use any default viewers for image types. Note that open is used as
  178. * the default for NeXT, instead of the XLOADIMAGE_COMMAND definition.
  179. */
  180. -#define XLOADIMAGE_COMMAND "xli %s &"
  181. +#define XLOADIMAGE_COMMAND NULL
  182. /**************************
  183. * For UNIX systems, SYSTEM_MAIL and SYSTEM_MAIL_FLAGS are set by the