0006-Look-for-NEWS-in-order-to-find-etc-rather-than-GNU.patch 1.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142
  1. From 82c8d54016a3c7c798464b06a439706359dd95e3 Mon Sep 17 00:00:00 2001
  2. From: Rob Browning <rlb@defaultvalue.org>
  3. Date: Mon, 4 Apr 2011 22:46:29 -0500
  4. Subject: Look for NEWS in order to find etc/ rather than GNU.
  5. Emacs will now look for NEWS in order to find etc/ rather than GNU.
  6. Since Debian doesn't include GNU in the Debian packages (the common
  7. licenses are in /usr/share/common-licenses), Emacs will now look for
  8. NEWS to find the etc directory instead of GNU.
  9. Provided-by: Sven Joachim <svenjoac@gmx.de>
  10. Originally-reported-by: Bernhard Michler <Boregard@gmx.net>
  11. Date: Mon, 28 Apr 2008 11:20:23 +0200
  12. Added-by: Rob Browning <rlb@defaultvalue.org>
  13. Status: Debian specific
  14. ---
  15. src/callproc.c | 4 ++--
  16. 1 file changed, 2 insertions(+), 2 deletions(-)
  17. diff --git a/src/callproc.c b/src/callproc.c
  18. index d3ca7eb..5bbb145 100644
  19. --- a/src/callproc.c
  20. +++ b/src/callproc.c
  21. @@ -1571,14 +1571,14 @@ init_callproc (void)
  22. srcdir = Fexpand_file_name (build_string ("../src/"),
  23. build_string (PATH_DUMPLOADSEARCH));
  24. - tem = Fexpand_file_name (build_string ("GNU"), Vdata_directory);
  25. + tem = Fexpand_file_name (build_string ("NEWS"), Vdata_directory);
  26. tem1 = Ffile_exists_p (tem);
  27. if (!NILP (Fequal (srcdir, Vinvocation_directory)) || NILP (tem1))
  28. {
  29. Lisp_Object newdir;
  30. newdir = Fexpand_file_name (build_string ("../etc/"),
  31. build_string (PATH_DUMPLOADSEARCH));
  32. - tem = Fexpand_file_name (build_string ("GNU"), newdir);
  33. + tem = Fexpand_file_name (build_string ("NEWS"), newdir);
  34. tem1 = Ffile_exists_p (tem);
  35. if (!NILP (tem1))
  36. Vdata_directory = newdir;