emacsVER-bin-common.postinst 473 B

12345678910111213141516171819202122
  1. #!/bin/sh
  2. set -e
  3. FLAVOR=@DEB_FLAVOR@
  4. MAJOR=@MAJOR_VERSION@
  5. MINOR=@MINOR_VERSION@
  6. FULL=@FULL_VERSION@
  7. ALTERNATIVES="@ALTERNATIVES@"
  8. BIN_PRIORITY=@BIN_PRIORITY@
  9. # update-alternatives on things that collide with xemacs, other editors
  10. for i in ${ALTERNATIVES}
  11. do
  12. update-alternatives \
  13. --install /usr/bin/$i $i /usr/bin/$i.${FLAVOR} ${BIN_PRIORITY} \
  14. --slave /usr/share/man/man1/$i.1.gz $i.1.gz \
  15. /usr/share/man/man1/$i.${FLAVOR}.1.gz
  16. done
  17. #DEBHELPER#