0005-Modify-the-output-of-version-to-indicate-Debian-modi.patch 1.1 KB

1234567891011121314151617181920212223242526272829
  1. From a8263831c854955871e4dc155989175470e1919b Mon Sep 17 00:00:00 2001
  2. From: Rob Browning <rlb@defaultvalue.org>
  3. Date: Mon, 4 Apr 2011 22:46:28 -0500
  4. Subject: Modify the output of (version) to indicate Debian modifications.
  5. The output of (version) has been modified to indicate Debian modifications.
  6. Author: Rob Browning <rlb@defaultvalue.org>
  7. Added-by: Rob Browning <rlb@defaultvalue.org>
  8. ---
  9. lisp/version.el | 4 ++--
  10. 1 file changed, 2 insertions(+), 2 deletions(-)
  11. diff --git a/lisp/version.el b/lisp/version.el
  12. index bd30f0f..7de3f1b 100644
  13. --- a/lisp/version.el
  14. +++ b/lisp/version.el
  15. @@ -51,8 +51,8 @@ to the system configuration; look at `system-configuration' instead."
  16. (interactive "P")
  17. (let ((version-string
  18. (format (if (not (called-interactively-p 'interactive))
  19. - "GNU Emacs %s (%s%s%s)\n of %s on %s"
  20. - "GNU Emacs %s (%s%s%s) of %s on %s")
  21. + "GNU Emacs %s (%s%s%s)\n of %s on %s, modified by Debian"
  22. + "GNU Emacs %s (%s%s%s) of %s on %s, modified by Debian")
  23. emacs-version
  24. system-configuration
  25. (cond ((featurep 'motif)