ratpoison.scm 3.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
  3. ;;; Copyright © 2015 Mathieu Lirzin <mthl@openmailbox.org>
  4. ;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
  5. ;;;
  6. ;;; This file is part of GNU Guix.
  7. ;;;
  8. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  9. ;;; under the terms of the GNU General Public License as published by
  10. ;;; the Free Software Foundation; either version 3 of the License, or (at
  11. ;;; your option) any later version.
  12. ;;;
  13. ;;; GNU Guix is distributed in the hope that it will be useful, but
  14. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  15. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  16. ;;; GNU General Public License for more details.
  17. ;;;
  18. ;;; You should have received a copy of the GNU General Public License
  19. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  20. (define-module (gnu packages ratpoison)
  21. #:use-module (guix packages)
  22. #:use-module (guix download)
  23. #:use-module (guix build-system gnu)
  24. #:use-module ((guix licenses) #:select (gpl2+))
  25. #:use-module (gnu packages)
  26. #:use-module (gnu packages xorg)
  27. #:use-module (gnu packages perl)
  28. #:use-module (gnu packages readline)
  29. #:use-module (gnu packages pkg-config)
  30. #:use-module (gnu packages fontutils))
  31. (define ratpoison.desktop
  32. (origin
  33. (method url-fetch)
  34. (uri (string-append "https://sources.gentoo.org/cgi-bin/viewvc.cgi/"
  35. "gentoo-x86/x11-wm/ratpoison/files/ratpoison.desktop"
  36. "?revision=1.1"))
  37. (file-name "ratpoison.desktop")
  38. (sha256
  39. (base32
  40. "1rh3f4c3rhn6q2hmkraam0831xqcqyj3qkqf019ahaxsxaan3553"))))
  41. (define-public ratpoison
  42. (package
  43. (name "ratpoison")
  44. (version "1.4.9")
  45. (source
  46. (origin (method url-fetch)
  47. (uri (string-append "mirror://savannah/ratpoison/ratpoison-"
  48. version ".tar.xz"))
  49. (sha256
  50. (base32
  51. "1wfir1gvh5h7izgvx2kd1pr2k7wlncd33zq7qi9s9k2y0aza93yr"))
  52. (patches (search-patches "ratpoison-shell.patch"))))
  53. (build-system gnu-build-system)
  54. (arguments
  55. '(#:phases
  56. (modify-phases %standard-phases
  57. (add-after 'install 'install-xsession
  58. (lambda* (#:key inputs outputs #:allow-other-keys)
  59. (let ((rpd "ratpoison.desktop")
  60. (dst (string-append (assoc-ref outputs "out")
  61. "/share/xsessions/")))
  62. (mkdir-p dst)
  63. (copy-file (assoc-ref inputs rpd)
  64. (string-append dst rpd))))))))
  65. (inputs
  66. `(("inputproto" ,inputproto)
  67. ("fontconfig" ,fontconfig)
  68. ("freetype" ,freetype)
  69. ("libXft" ,libxft)
  70. ("libXi" ,libxi)
  71. ("libxrandr" ,libxrandr)
  72. ("libXpm" ,libxpm)
  73. ("libXt" ,libxt)
  74. ("libXtst" ,libxtst)
  75. ("libX11" ,libx11)
  76. ("readline" ,readline)
  77. ("xextproto" ,xextproto)))
  78. (native-inputs
  79. `(("perl",perl)
  80. ("pkg-config" ,pkg-config)
  81. ("ratpoison.desktop" ,ratpoison.desktop)))
  82. (home-page "http://www.nongnu.org/ratpoison/")
  83. (synopsis "Simple mouse-free tiling window manager")
  84. (description
  85. "Ratpoison is a simple window manager with no fat library
  86. dependencies, no fancy graphics, no window decorations, and no
  87. rodent dependence. It is largely modelled after GNU Screen which
  88. has done wonders in the virtual terminal market.
  89. The screen can be split into non-overlapping frames. All windows
  90. are kept maximized inside their frames to take full advantage of
  91. your precious screen real estate.
  92. All interaction with the window manager is done through keystrokes.
  93. Ratpoison has a prefix map to minimize the key clobbering that
  94. cripples Emacs and other quality pieces of software.")
  95. (license gpl2+)))