hardware-configuration.nix 518 B

1234567891011121314151617181920212223242526
  1. { modulesPath, ... }:
  2. {
  3. imports = [ (modulesPath + "/profiles/qemu-guest.nix") ];
  4. boot.loader.grub = {
  5. efiSupport = true;
  6. efiInstallAsRemovable = true;
  7. device = "nodev";
  8. };
  9. fileSystems."/boot" = {
  10. device = "/dev/disk/by-uuid/0D60-CDE2";
  11. fsType = "vfat";
  12. };
  13. boot.initrd.availableKernelModules = [
  14. "ata_piix"
  15. "uhci_hcd"
  16. "xen_blkfront"
  17. "vmw_pvscsi"
  18. ];
  19. boot.initrd.kernelModules = [ "nvme" ];
  20. fileSystems."/" = {
  21. device = "/dev/sda1";
  22. fsType = "ext4";
  23. };
  24. }