hardware-configuration.nix 517 B

12345678910111213141516171819202122232425
  1. { modulesPath, ... }:
  2. {
  3. imports = [ (modulesPath + "/profiles/qemu-guest.nix") ];
  4. boot.loader.grub = {
  5. efiSupport = true;
  6. efiInstallAsRemovable = true;
  7. device = "nodev";
  8. };
  9. fileSystems."/boot" = {
  10. device = "/dev/disk/by-uuid/4875-017B";
  11. fsType = "vfat";
  12. };
  13. boot.initrd.availableKernelModules = [
  14. "ata_piix"
  15. "uhci_hcd"
  16. "xen_blkfront"
  17. ];
  18. boot.initrd.kernelModules = [ "nvme" ];
  19. fileSystems."/" = {
  20. device = "/dev/mapper/ocivolume-root";
  21. fsType = "xfs";
  22. };
  23. }