endgame-singularity.SlackBuild 3.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114
  1. #!/bin/sh
  2. # Slackware build script for Endgame: Singularity
  3. # Copyright 2021- CRTS
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. # Another slackbuild already installs an executable named singularity
  23. # therefore the executable will be renamed to endgame-singularity
  24. PRGNAM=endgame-singularity
  25. VERSION=${VERSION:-1.00}
  26. BUILD=${BUILD:-1}
  27. TAG=${TAG:-_SBo}
  28. SRCNAM=singularity
  29. MUSICNAM=endgame-singularity-music-007
  30. if [ -z "$ARCH" ]; then
  31. case "$( uname -m )" in
  32. i?86) ARCH=i586 ;;
  33. arm*) ARCH=arm ;;
  34. *) ARCH=$( uname -m ) ;;
  35. esac
  36. fi
  37. CWD=$(pwd)
  38. TMP=${TMP:-/tmp/SBo}
  39. PKG=$TMP/package-$PRGNAM
  40. OUTPUT=${OUTPUT:-/tmp}
  41. if [ "$ARCH" = "i586" ]; then
  42. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  43. LIBDIRSUFFIX=""
  44. elif [ "$ARCH" = "i686" ]; then
  45. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  46. LIBDIRSUFFIX=""
  47. elif [ "$ARCH" = "x86_64" ]; then
  48. SLKCFLAGS="-O2 -fPIC"
  49. LIBDIRSUFFIX="64"
  50. else
  51. SLKCFLAGS="-O2"
  52. LIBDIRSUFFIX=""
  53. fi
  54. set -e
  55. rm -rf $PKG
  56. mkdir -p $TMP $PKG $OUTPUT
  57. cd $TMP
  58. rm -rf $SRCNAM-$VERSION
  59. tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
  60. cd $SRCNAM-$VERSION
  61. chown -R root:root .
  62. find -L . \
  63. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  64. -o -perm 511 \) -exec chmod 755 {} \; -o \
  65. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  66. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  67. # patch *.desktop file to avoid naming conflict
  68. patch $SRCNAM.desktop < $CWD/$SRCNAM.desktop.patch
  69. python3 setup.py install --root=$PKG
  70. # rename to avoid naming conflict
  71. mv $PKG/usr/bin/$SRCNAM $PKG/usr/bin/$PRGNAM
  72. # install music if present
  73. if [ -f $CWD/$MUSICNAM.zip ];then
  74. PYTHON=python$(python3 -c 'import sys; print(sys.version[:3])')
  75. unzip $CWD/$MUSICNAM.zip
  76. mv $MUSICNAM $PKG/usr/lib$LIBDIRSUFFIX/$PYTHON/site-packages/$SRCNAM/music
  77. fi
  78. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  79. cp -a \
  80. AUTHORS.txt CONTRIBUTING.md Changelog.txt \
  81. LICENSE.CC-BY-SA-3.txt LICENSE.cc0.txt \
  82. LICENSE.gpl.txt LICENSE.txt \
  83. README.txt TODO \
  84. $PKG/usr/doc/$PRGNAM-$VERSION
  85. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  86. mkdir -p $PKG/install
  87. cat $CWD/slack-desc > $PKG/install/slack-desc
  88. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  89. install -m 0644 -p -D $SRCNAM/data/themes/default/images/icon.png $PKG/usr/share/pixmaps/$PRGNAM.png
  90. mkdir -p $PKG/usr/share/applications
  91. # rename to avoid naming conflict
  92. cat $SRCNAM.desktop > $PKG/usr/share/applications/$PRGNAM.desktop
  93. cd $PKG
  94. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}