maven-parent-pom.scm 23 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2020, 2021, 2022 Julien Lepiller <julien@lepiller.eu>
  3. ;;;
  4. ;;; This file is part of GNU Guix.
  5. ;;;
  6. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  7. ;;; under the terms of the GNU General Public License as published by
  8. ;;; the Free Software Foundation; either version 3 of the License, or (at
  9. ;;; your option) any later version.
  10. ;;;
  11. ;;; GNU Guix is distributed in the hope that it will be useful, but
  12. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  13. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  14. ;;; GNU General Public License for more details.
  15. ;;;
  16. ;;; You should have received a copy of the GNU General Public License
  17. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  18. (define-module (gnu packages maven-parent-pom)
  19. #:use-module ((guix licenses) #:prefix license:)
  20. #:use-module (guix packages)
  21. #:use-module (guix download)
  22. #:use-module (guix gexp)
  23. #:use-module (guix git-download)
  24. #:use-module (guix utils)
  25. #:use-module (guix build-system ant)
  26. #:use-module (gnu packages java))
  27. (define (make-apache-parent-pom version hash)
  28. (hidden-package
  29. (package
  30. (name "apache-parent-pom")
  31. (version version)
  32. (source (origin
  33. (method git-fetch)
  34. (uri (git-reference
  35. (url "https://github.com/apache/maven-apache-parent")
  36. (commit (string-append "apache-" version))))
  37. (file-name (git-file-name name version))
  38. (sha256 (base32 hash))))
  39. (build-system ant-build-system)
  40. (arguments
  41. `(#:tests? #f
  42. #:phases
  43. (modify-phases %standard-phases
  44. (delete 'configure)
  45. (delete 'build)
  46. (replace 'install
  47. (install-pom-file "pom.xml")))))
  48. (home-page "https://apache.org/")
  49. (synopsis "Apache parent pom")
  50. (description "This package contains the Apache parent POM.")
  51. (license license:asl2.0))))
  52. (define-public apache-parent-pom-6
  53. (make-apache-parent-pom
  54. "6" "1bq0ma2ya2cnp2icd4l20sv6y7zxqr9sa35wzv1s49nqsrm38kw3"))
  55. (define-public apache-parent-pom-11
  56. (make-apache-parent-pom
  57. "11" "0m1a4db8s6y8f4vvm9bx7zx7lixcvaah064560nbja7na3xz6lls"))
  58. (define-public apache-parent-pom-13
  59. (make-apache-parent-pom
  60. "13" "1cfxaz1jy8fbn06sb648qpiq23swpbj3kb5ya7f9g9jmya5fy09z"))
  61. (define-public apache-parent-pom-16
  62. (make-apache-parent-pom
  63. "16" "1y5b0dlc72ijcqfffdbh0k75qwaddy5qw725v9pzhrzqkpaa51xb"))
  64. (define-public apache-parent-pom-17
  65. (make-apache-parent-pom
  66. "17" "06hj5d6rdkmwl24k2rvzj8plq8x1ncsbjck4w3awz1hp9gngg4y5"))
  67. (define-public apache-parent-pom-18
  68. (make-apache-parent-pom
  69. "18" "1il97vpdmv5k2gnyinj45q00f7f4w9hcb588digwfid5bskddnyy"))
  70. (define-public apache-parent-pom-19
  71. (make-apache-parent-pom
  72. "19" "02drnwv2qqk1dmxbmmrk0bi1iil5cal9l47w53ascpbjg6242mp1"))
  73. (define-public apache-parent-pom-21
  74. (make-apache-parent-pom
  75. "21" "0clcbrq1b2b8sbvlqddyw2dg5niq25dhdma9sk4b0i30hqaipx96"))
  76. (define-public apache-parent-pom-23
  77. (make-apache-parent-pom
  78. "23" "05c8i741f0m4311q264zvq0lc6srsyz2x95ga4d7qfd89swkzg9d"))
  79. (define-public apache-parent-pom-25
  80. (make-apache-parent-pom
  81. "25" "1vwx2fpgk7cn2pnlnx26df26vndiwwn5l7ngakj0vwal5pmp6115"))
  82. (define* (make-apache-commons-parent-pom version hash parent
  83. #:key (tag-prefix "commons-parent-"))
  84. (hidden-package
  85. (package
  86. (name "apache-commons-parent-pom")
  87. (version version)
  88. (source (origin
  89. (method git-fetch)
  90. (uri (git-reference
  91. (url "https://github.com/apache/commons-parent")
  92. (commit (string-append tag-prefix version))))
  93. (file-name (git-file-name name version))
  94. (sha256 (base32 hash))))
  95. (build-system ant-build-system)
  96. (arguments
  97. `(#:tests? #f
  98. #:phases
  99. (modify-phases %standard-phases
  100. (delete 'configure)
  101. (delete 'build)
  102. (replace 'install
  103. (install-pom-file "pom.xml")))))
  104. (propagated-inputs
  105. (if parent
  106. `(("parent" ,parent))
  107. '()))
  108. (home-page "https://maven.apache.org/")
  109. (synopsis "Apache Commons parent pom")
  110. (description "This package contains the Apache Commons parent POM.")
  111. (license license:asl2.0))))
  112. (define-public apache-commons-parent-pom-39
  113. (make-apache-commons-parent-pom
  114. "39" "0mjx48a55ik1h4hsxhifkli1flvkp6d05ab14p4al0fc6rhdxi46"
  115. apache-parent-pom-16))
  116. (define-public apache-commons-parent-pom-41
  117. (make-apache-commons-parent-pom
  118. "41" "1k184amdqdx62bb2k0m9v93zzx768qcyam5dvdgksqc1aaqhadlb"
  119. apache-parent-pom-18))
  120. (define-public apache-commons-parent-pom-48
  121. (make-apache-commons-parent-pom
  122. "48" "0dk8qp7swbh4y1q7q34y14yhigzl5yz0ixa8jhhhq91yc2q570iq"
  123. apache-parent-pom-21))
  124. (define-public apache-commons-parent-pom-50
  125. (make-apache-commons-parent-pom
  126. "50" "0ki8px35dan51ashblpw6rdl27c2fq62slazhslhq3lr4fwlpvxs"
  127. apache-parent-pom-21))
  128. (define-public apache-commons-parent-pom-51
  129. (make-apache-commons-parent-pom
  130. "51" "05najrpys26jymla2p5jdz4mf4fjp525h6mnr0jfx55lp03xi939"
  131. apache-parent-pom-23))
  132. (define-public apache-commons-parent-pom-52
  133. (make-apache-commons-parent-pom
  134. "52" "0fb6id9cs9944fjlirjc07bf234bwi96i642px09m9nrfj338n5d"
  135. apache-parent-pom-23
  136. #:tag-prefix "rel/commons-parent-"))
  137. (define-public java-weld-parent-pom
  138. (hidden-package
  139. (package
  140. (name "java-weld-parent-pom")
  141. (version "36")
  142. (source (origin
  143. (method git-fetch)
  144. (uri (git-reference
  145. (url "https://github.com/weld/parent")
  146. (commit version)))
  147. (file-name (git-file-name name version))
  148. (sha256
  149. (base32
  150. "0rbvizcsma456mw9fvp4dj9cljh97nswvhi04xhczi38j5bgal0m"))))
  151. (build-system ant-build-system)
  152. (arguments
  153. `(#:tests? #f
  154. #:phases
  155. (modify-phases %standard-phases
  156. (delete 'build)
  157. (replace 'install
  158. (install-pom-file "pom.xml")))))
  159. (home-page "https://github.com/weld/parent")
  160. (synopsis "Pom parent file for weld projects")
  161. (description "This package contains the parent Maven Pom for weld projects.")
  162. (license license:asl2.0))))
  163. (define (make-java-sonatype-forge-parent-pom version hash)
  164. (hidden-package
  165. (package
  166. (name "java-sonatype-forge-parent-pom")
  167. (version version)
  168. (source (origin
  169. (method git-fetch)
  170. (uri (git-reference
  171. (url "https://github.com/sonatype/oss-parents")
  172. (commit (string-append "forge-parent-" version))))
  173. (file-name (git-file-name name version))
  174. (sha256 (base32 hash))))
  175. (build-system ant-build-system)
  176. (arguments
  177. `(#:tests? #f
  178. #:phases
  179. (modify-phases %standard-phases
  180. (delete 'build)
  181. (delete 'configure)
  182. (replace 'install
  183. (install-pom-file "pom.xml")))))
  184. (home-page "https://github.com/sonatype/oss-parents")
  185. (synopsis "Sonatype forge parent pom")
  186. (description "This package contains a single pom.xml file that is used by
  187. other projects as their parent pom.")
  188. (license license:asl2.0))))
  189. (define-public java-sonatype-forge-parent-pom-4
  190. (make-java-sonatype-forge-parent-pom
  191. "4" "1gip239ar20qzy6yf37r6ks54bl7gqi1v49p65manrz84cmad0dh"))
  192. (define-public java-sonatype-forge-parent-pom-5
  193. (make-java-sonatype-forge-parent-pom
  194. "5" "0pr60wyjmaml4flmcij6l94b72ryx5gsiiasiwvcvrz9b2fkb3cd"))
  195. (define-public java-sonatype-forge-parent-pom-6
  196. (make-java-sonatype-forge-parent-pom
  197. "6" "0sa5wn5kc6y74m9g3azkm5i9d7kvyvgdw7wjlp7bjgy9s5qkbhgz"))
  198. (define-public java-sonatype-forge-parent-pom-10
  199. (make-java-sonatype-forge-parent-pom
  200. "10" "1n89wb00q4s9nwpqq6q1h4nzakw1l1rppjygxkl3iid7m5fnj60n"))
  201. (define-public java-sonatype-spice-parent-pom-15
  202. (hidden-package
  203. (package
  204. (name "java-sonatype-spice-parent-pom")
  205. (version "15")
  206. (source (origin
  207. (method git-fetch)
  208. (uri (git-reference
  209. (url "https://github.com/sonatype/oss-parents")
  210. ;; The only commit where spice-parent is version 15
  211. (commit "a4d1169c66fb21b214cb3eff2f056ec3e3695ca7")))
  212. (file-name (git-file-name name version))
  213. (sha256
  214. (base32
  215. "0h62h6m31srmqnd1bhyspz6hdhkkv48knkj0ximq3pzdixgzyxgy"))))
  216. (build-system ant-build-system)
  217. (propagated-inputs
  218. `(("java-sonatype-forge-parent-pom-5" ,java-sonatype-forge-parent-pom-5)))
  219. (arguments
  220. `(#:tests? #f
  221. #:phases
  222. (modify-phases %standard-phases
  223. (delete 'build)
  224. (delete 'configure)
  225. (replace 'install
  226. (install-pom-file "pom.xml")))))
  227. (home-page "https://github.com/sonatype/oss-parents")
  228. (synopsis "Sonatype spice parent pom")
  229. (description "This package contains a single pom.xml file that is used by
  230. other projects as their parent pom.")
  231. (license license:asl2.0))))
  232. (define-public java-sonatype-spice-parent-pom-17
  233. (hidden-package
  234. (package
  235. (inherit java-sonatype-spice-parent-pom-15)
  236. (version "17")
  237. (source (origin
  238. (method git-fetch)
  239. (uri (git-reference
  240. (url "https://github.com/sonatype/oss-parents")
  241. (commit "spice-parent-17")))
  242. (file-name (git-file-name "java-sonatype-spice-parent-pom" version))
  243. (sha256
  244. (base32
  245. "1d4jh1scgnjwhv8f0r052vrksg0kman09hslfvfvpfidl8rwiigq"))))
  246. (arguments
  247. `(#:tests? #f
  248. #:phases
  249. (modify-phases %standard-phases
  250. (delete 'build)
  251. (delete 'configure)
  252. (replace 'install
  253. (install-pom-file "spice-parent/pom.xml")))))
  254. (propagated-inputs
  255. `(("java-sonatype-forge-parent-pom-10" ,java-sonatype-forge-parent-pom-10))))))
  256. (define-public java-sonatype-spice-parent-pom-12
  257. (hidden-package
  258. (package
  259. (inherit java-sonatype-spice-parent-pom-15)
  260. (version "12")
  261. (source (origin
  262. (method git-fetch)
  263. (uri (git-reference
  264. (url "https://github.com/sonatype/oss-parents")
  265. ;; The only commit where spice-parent is version 12
  266. (commit "95088ae2891f673828351d7d9150240859b4a29a")))
  267. (file-name (git-file-name "java-sonatype-spice-parent-pom" version))
  268. (sha256
  269. (base32
  270. "0pq5yf6swn43rxdfksnqsky1402zza2xq1aypwma9jkck2yl0vma"))))
  271. (propagated-inputs
  272. `(("java-sonatype-forge-parent-pom-4" ,java-sonatype-forge-parent-pom-4))))))
  273. (define-public java-sonatype-oss-parent-pom-7
  274. (hidden-package
  275. (package
  276. (name "java-sonatype-oss-parent-pom")
  277. (version "7")
  278. (source (origin
  279. (method git-fetch)
  280. (uri (git-reference
  281. (url "https://github.com/sonatype/oss-parents")
  282. (commit (string-append "oss-parent-" version))))
  283. (file-name (git-file-name name version))
  284. (sha256
  285. (base32
  286. "0lkvkmm51vrrrp79ksq3i2v693279rbn06yxck70ivhjrbq77927"))))
  287. (build-system ant-build-system)
  288. (arguments
  289. `(#:tests? #f
  290. #:phases
  291. (modify-phases %standard-phases
  292. (delete 'build)
  293. (delete 'configure)
  294. (replace 'install
  295. (install-pom-file "pom.xml")))))
  296. (home-page "https://github.com/sonatype/oss-parents")
  297. (synopsis "Sonatype oss parent pom")
  298. (description "This package contains a single pom.xml file that is used by
  299. other projects as their parent pom.")
  300. (license license:asl2.0))))
  301. (define-public java-sonatype-oss-parent-pom-9
  302. (hidden-package
  303. (package
  304. (inherit java-sonatype-oss-parent-pom-7)
  305. (version "9")
  306. (source (origin
  307. (method url-fetch)
  308. (uri (string-append "https://repo1.maven.org/maven2/org/sonatype/"
  309. "oss/oss-parent/" version "/oss-parent-"
  310. version ".pom"))
  311. (sha256
  312. (base32
  313. "0yl2hbwz2kn1hll1i00ddzn8f89bfdcjwdifz0pj2j15k1gjch7v"))))
  314. (arguments
  315. (list
  316. #:tests? #f
  317. #:phases
  318. #~(modify-phases %standard-phases
  319. (delete 'unpack)
  320. (delete 'configure)
  321. (delete 'build)
  322. (replace 'install
  323. (install-pom-file #$(package-source this-package)))))))))
  324. (define* (make-plexus-parent-pom version hash #:optional parent)
  325. (hidden-package
  326. (package
  327. (name "plexus-parent-pom")
  328. (version version)
  329. (source (origin
  330. (method git-fetch)
  331. (uri (git-reference
  332. (url "https://github.com/codehaus-plexus/plexus-pom")
  333. (commit (string-append "plexus-" version))))
  334. (file-name (git-file-name name version))
  335. (sha256 (base32 hash))))
  336. (build-system ant-build-system)
  337. (arguments
  338. `(#:tests? #f
  339. #:phases
  340. (modify-phases %standard-phases
  341. (delete 'configure)
  342. (delete 'build)
  343. (replace 'install
  344. (install-pom-file "pom.xml")))))
  345. (propagated-inputs
  346. (if parent
  347. `(("parent" ,parent))
  348. '()))
  349. (home-page "https://codehaus-plexus.github.io/plexus-pom")
  350. (synopsis "Plexus parent pom")
  351. (description "This package contains the Plexus parent POM.")
  352. (license license:asl2.0))))
  353. (define-public plexus-parent-pom-3.1
  354. (make-plexus-parent-pom
  355. "3.1" "0r1wa6zrpzynn4028w7880abkk2xk25mipav5f0a4d1abqzy5m53"
  356. java-sonatype-spice-parent-pom-17))
  357. (define-public plexus-parent-pom-4.0
  358. (make-plexus-parent-pom
  359. "4.0" "15xbvc3cqhdkli8sj2l4hqkvk6icikbj182fbm86ixkamjh5lyfk"
  360. java-sonatype-forge-parent-pom-10))
  361. (define-public plexus-parent-pom-5.1
  362. (make-plexus-parent-pom
  363. "5.1" "1mb87adzyv8lilzd6sw40j5000vhib2p0lgf9zzgggpkh79ddm8v"))
  364. (define-public plexus-parent-pom-6.1
  365. (make-plexus-parent-pom
  366. "6.1" "1pisca0fxpgbhf4xdgw5mn86622pg3mc5b8760kf9mk2awazshlj"))
  367. (define-public plexus-parent-pom-8
  368. (make-plexus-parent-pom
  369. "8" "0ybwdzawa58qg9ag39rxyin24lk9sjcaih6n2yfldfzsbkq6gnww"))
  370. (define* (make-maven-parent-pom version hash parent #:key replacements)
  371. (hidden-package
  372. (package
  373. (name "maven-parent-pom")
  374. (version version)
  375. (source (origin
  376. (method git-fetch)
  377. (uri (git-reference
  378. (url "https://github.com/apache/maven-parent")
  379. (commit (string-append "maven-parent-" version))))
  380. (file-name (git-file-name name version))
  381. (sha256 (base32 hash))))
  382. (build-system ant-build-system)
  383. (arguments
  384. `(#:tests? #f
  385. #:phases
  386. (modify-phases %standard-phases
  387. (delete 'configure)
  388. (delete 'build)
  389. (add-after 'install 'install-plugins
  390. (install-pom-file "maven-plugins/pom.xml"))
  391. (add-after 'install 'install-shared
  392. (install-pom-file "maven-shared-components/pom.xml"))
  393. ,@(if replacements
  394. `((add-before 'install 'fix-pom
  395. (lambda _
  396. (use-modules (guix build maven pom))
  397. (fix-pom-dependencies "pom.xml" '() #:local-packages (quote ,(force replacements))))))
  398. '())
  399. (replace 'install
  400. (install-pom-file "pom.xml")))))
  401. (propagated-inputs
  402. `(("parent" ,parent)))
  403. (home-page "https://maven.apache.org/")
  404. (synopsis "Maven parent pom")
  405. (description "Apache Maven is a software project management and comprehension
  406. tool. This package contains the Maven parent POM.")
  407. (license license:asl2.0))))
  408. (define-public maven-parent-pom-35
  409. (make-maven-parent-pom
  410. "35" "0pg9k7l5pcbghmc89i11g900pbzznvf5sfdfzlqfwpihqb2g8iab"
  411. apache-parent-pom-25
  412. #:replacements
  413. (delay
  414. `(("org.codehaus.plexus"
  415. ("plexus-component-annotations" .
  416. ,(package-version java-plexus-component-annotations)))))))
  417. (define-public maven-parent-pom-34
  418. (make-maven-parent-pom
  419. "34" "1vkmrfwva76k6maf1ljbja5ga4kzav4xc73ymbaf42xaiaknglbc"
  420. apache-parent-pom-23
  421. #:replacements
  422. (delay
  423. `(("org.codehaus.plexus"
  424. ("plexus-component-annotations" .
  425. ,(package-version java-plexus-component-annotations)))))))
  426. (define-public maven-parent-pom-33
  427. (make-maven-parent-pom
  428. "33" "1b0z2gsvpccgcssys9jbdfwlwq8b5imdwr508f87ssdbfs29lh65"
  429. apache-parent-pom-21
  430. #:replacements
  431. (delay
  432. `(("org.codehaus.plexus"
  433. ("plexus-component-annotations" .
  434. ,(package-version java-plexus-component-annotations)))))))
  435. (define-public maven-parent-pom-31
  436. (make-maven-parent-pom
  437. "31" "0skxv669v9ffwbmrmybnn9awkf1g3ylk88bz0hv6g11zpj1a8454"
  438. apache-parent-pom-19
  439. #:replacements
  440. (delay
  441. `(("org.codehaus.plexus"
  442. ("plexus-component-annotations" .
  443. ,(package-version java-plexus-component-annotations)))))))
  444. (define-public maven-parent-pom-30
  445. (make-maven-parent-pom
  446. "30" "1w463na38v2054wn1cwbfqy095z13fhil4jmn08dsa4drdvdsjdw"
  447. apache-parent-pom-18))
  448. (define-public maven-parent-pom-27
  449. (let ((base (make-maven-parent-pom
  450. "27" "1s31hi4n99kj7x1cy5dvzwldbjqzk6c3dn20hk61hwhgmkcbf14x"
  451. apache-parent-pom-17)))
  452. (package
  453. (inherit base)
  454. (arguments
  455. (substitute-keyword-arguments (package-arguments base)
  456. ((#:phases phases)
  457. `(modify-phases ,phases
  458. (delete 'install-plugins)
  459. (delete 'install-shared))))))))
  460. (define-public maven-parent-pom-15
  461. (let ((base (make-maven-parent-pom
  462. "15" "154nbc3w9is1dpzlfi1xk03mfksxndnniyzq8mcw2wdbargb5504"
  463. apache-parent-pom-6)))
  464. (package
  465. (inherit base)
  466. (arguments
  467. (substitute-keyword-arguments (package-arguments base)
  468. ((#:phases phases)
  469. `(modify-phases ,phases
  470. (delete 'install-plugins)
  471. (delete 'install-shared))))))))
  472. (define-public maven-parent-pom-22
  473. (let ((base (make-maven-parent-pom
  474. "22" "1kgqbyx7ckashy47n9rgyg4asyrvp933hdiknvnad7msq5d4c2jg"
  475. apache-parent-pom-11
  476. #:replacements
  477. (delay
  478. `(("org.codehaus.plexus"
  479. ("plexus-component-annotations" .
  480. ,(package-version java-plexus-container-default))))))))
  481. (package
  482. (inherit base)
  483. (arguments
  484. (substitute-keyword-arguments (package-arguments base)
  485. ((#:phases phases)
  486. `(modify-phases ,phases
  487. (delete 'install-plugins)
  488. (delete 'install-shared))))))))
  489. (define-public maven-plugins-pom-23
  490. (hidden-package
  491. (package
  492. (name "maven-plugins-pom")
  493. (version "23")
  494. (source (origin
  495. (method git-fetch)
  496. (uri (git-reference
  497. (url "https://github.com/apache/maven-plugins")
  498. (commit (string-append "maven-plugins-" version))))
  499. (file-name (git-file-name "maven-plugins-pom" version))
  500. (sha256
  501. (base32
  502. "1j50il0c9kirr1cvf6vfr86wxp65lwqm9i4bz304ix12vv6ncxjq"))))
  503. (build-system ant-build-system)
  504. (arguments
  505. `(#:tests? #f
  506. #:phases
  507. (modify-phases %standard-phases
  508. (delete 'configure)
  509. (delete 'build)
  510. (replace 'install
  511. (install-pom-file "pom.xml")))))
  512. (propagated-inputs
  513. (list maven-parent-pom-22))
  514. (home-page "https://github.com/apache/maven-plugins")
  515. (synopsis "Maven parent pom for maven plugins projects")
  516. (description "This package contains the parent pom for maven plugins.")
  517. (license license:asl2.0))))
  518. (define-public maven-components-parent-pom-22
  519. (hidden-package
  520. (package
  521. (name "maven-components-parent-pom")
  522. (version "22")
  523. (source (origin
  524. (method url-fetch)
  525. (uri (string-append "https://repo1.maven.org/maven2/org/apache/"
  526. "maven/shared/maven-shared-components/22/"
  527. "maven-shared-components-22.pom"))
  528. (sha256
  529. (base32
  530. "11skhrjgrrs6z5rw1w39ap1pzhrc99g0czip10kz7wsavg746ibm"))))
  531. (build-system ant-build-system)
  532. (arguments
  533. (list
  534. #:tests? #f
  535. #:phases
  536. #~(modify-phases %standard-phases
  537. (delete 'unpack)
  538. (delete 'build)
  539. (delete 'configure)
  540. (replace 'install
  541. (install-pom-file #$(package-source this-package))))))
  542. (propagated-inputs
  543. `(("maven-parent-pom-27" ,maven-parent-pom-27)))
  544. (home-page "https://apache.org/maven")
  545. (synopsis "Parent pom file for the maven components")
  546. (description "This package contains the parent pom files for maven shared
  547. components.")
  548. (license license:lgpl2.1+))))
  549. (define-public maven-components-parent-pom-21
  550. (package
  551. (inherit maven-components-parent-pom-22)
  552. (source (origin
  553. (method url-fetch)
  554. (uri (string-append "https://repo1.maven.org/maven2/org/apache/"
  555. "maven/shared/maven-shared-components/21/"
  556. "maven-shared-components-21.pom"))
  557. (sha256
  558. (base32
  559. "0cqa072fz55j5xyvixqv8vbd7jsbhb1cd14bzjvm0hbv2wpd9npf"))))))
  560. (define-public java-jvnet-parent-pom-3
  561. (hidden-package
  562. (package
  563. (name "java-jvnet-parent-pom-3")
  564. (version "3")
  565. (source (origin
  566. (method url-fetch)
  567. (uri (string-append "https://repo1.maven.org/maven2/net/java/"
  568. "jvnet-parent/" version "/jvnet-parent-"
  569. version ".pom"))
  570. (sha256
  571. (base32
  572. "0nj7958drckwf634cw9gmwgmdi302bya7bas16bbzp9rzag7ix9h"))))
  573. (build-system ant-build-system)
  574. (arguments
  575. (list
  576. #:tests? #f
  577. #:phases
  578. #~(modify-phases %standard-phases
  579. (delete 'unpack)
  580. (delete 'configure)
  581. (delete 'build)
  582. (replace 'install
  583. (install-pom-file #$(package-source this-package))))))
  584. (home-page "https://mvnrepository.com/artifact/net.java/jvnet-parent")
  585. (synopsis "java.net parent pom")
  586. (description "This package contains the java.net parent pom file.")
  587. (license license:asl2.0))))