123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766 |
- ;;; GNU Guix --- Functional package management for GNU
- ;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
- ;;; Copyright © 2014 Kevin Lemonnier <lemonnierk@ulrar.net>
- ;;; Copyright © 2015, 2017 Ludovic Courtès <ludo@gnu.org>
- ;;; Copyright © 2015-2023 Efraim Flashner <efraim@flashner.co.il>
- ;;; Copyright © 2016 Nikita <nikita@n0.is>
- ;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
- ;;; Copyright © 2017–2022 Tobias Geerinckx-Rice <me@tobias.gr>
- ;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
- ;;; Copyright © 2020, 2021, 2022 Vinicius Monego <monego@posteo.net>
- ;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
- ;;; Copyright © 2020 Brett Gilio <brettg@gnu.org>
- ;;; Copyright © 2021 WinterHound <winterhound@yandex.com>
- ;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
- ;;; Copyright © 2022 jgart <jgart@dismail.de>
- ;;;
- ;;; This file is part of GNU Guix.
- ;;;
- ;;; GNU Guix is free software; you can redistribute it and/or modify it
- ;;; under the terms of the GNU General Public License as published by
- ;;; the Free Software Foundation; either version 3 of the License, or (at
- ;;; your option) any later version.
- ;;;
- ;;; GNU Guix is distributed in the hope that it will be useful, but
- ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
- ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- ;;; GNU General Public License for more details.
- ;;;
- ;;; You should have received a copy of the GNU General Public License
- ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
- (define-module (gnu packages irc)
- #:use-module (guix gexp)
- #:use-module ((guix licenses) #:prefix license:)
- #:use-module (guix download)
- #:use-module (guix git-download)
- #:use-module (guix utils)
- #:use-module (guix packages)
- #:use-module (guix utils)
- #:use-module (guix build-system cmake)
- #:use-module (guix build-system gnu)
- #:use-module (guix build-system go)
- #:use-module (guix build-system meson)
- #:use-module (guix build-system python)
- #:use-module (guix build-system qt)
- #:use-module (gnu packages)
- #:use-module (gnu packages admin)
- #:use-module (gnu packages aspell)
- #:use-module (gnu packages autogen)
- #:use-module (gnu packages autotools)
- #:use-module (gnu packages base)
- #:use-module (gnu packages backup)
- #:use-module (gnu packages boost)
- #:use-module (gnu packages check)
- #:use-module (gnu packages code)
- #:use-module (gnu packages compression)
- #:use-module (gnu packages curl)
- #:use-module (gnu packages cyrus-sasl)
- #:use-module (gnu packages databases)
- #:use-module (gnu packages file)
- #:use-module (gnu packages gettext)
- #:use-module (gnu packages geo)
- #:use-module (gnu packages glib)
- #:use-module (gnu packages gnome)
- #:use-module (gnu packages gnupg)
- #:use-module (gnu packages golang)
- #:use-module (gnu packages gtk)
- #:use-module (gnu packages guile)
- #:use-module (gnu packages lua)
- #:use-module (gnu packages lxqt)
- #:use-module (gnu packages man)
- #:use-module (gnu packages ncurses)
- #:use-module (gnu packages openldap)
- #:use-module (gnu packages kde)
- #:use-module (gnu packages kde-frameworks)
- #:use-module (gnu packages password-utils)
- #:use-module (gnu packages pcre)
- #:use-module (gnu packages perl)
- #:use-module (gnu packages pkg-config)
- #:use-module (gnu packages python)
- #:use-module (gnu packages python-crypto)
- #:use-module (gnu packages python-xyz)
- #:use-module (gnu packages regex)
- #:use-module (gnu packages ruby)
- #:use-module (gnu packages sphinx)
- #:use-module (gnu packages sqlite)
- #:use-module (gnu packages qt)
- #:use-module (gnu packages tcl)
- #:use-module (gnu packages textutils)
- #:use-module (gnu packages time)
- #:use-module (gnu packages tls)
- #:use-module (gnu packages web)
- #:use-module (srfi srfi-1)
- #:use-module (srfi srfi-26))
- (define-public quassel
- (package
- (name "quassel")
- (version "0.14.0")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "https://quassel-irc.org/pub/quassel-"
- version ".tar.xz"))
- (sha256
- (base32
- "042fzssydvv35jjknziph8iyyjsyrsb2hp3d0ix0bqbagbrpf1q9"))
- (modules '((guix build utils)))
- ;; We don't want to install the bundled inxi script.
- (snippet
- '(begin
- (delete-file "data/scripts/inxi")))))
- (build-system qt-build-system)
- (arguments
- ;; The three binaries are not mutually exlusive, and are all built
- ;; by default.
- '(#:configure-flags '("-DBUILD_TESTING=ON"
- ;;"-DWANT_QTCLIENT=OFF"
- ;;"-DWANT_CORE=OFF"
- ;;"-DWANT_MONO=OFF"
- "-DWITH_KDE=OFF"
- "-DWITH_BUNDLED_ICONS=ON"
- "-DWITH_OXYGEN_ICONS=ON"
- ;; This disables link previews.
- "-DWITH_WEBENGINE=OFF")
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-inxi-reference
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((inxi (search-input-file inputs "/bin/inxi")))
- (symlink inxi "data/scripts/inxi")))))))
- (native-inputs
- (list extra-cmake-modules pkg-config qttools-5))
- (inputs
- (list boost
- inxi-minimal
- libdbusmenu-qt
- perl
- qca
- qtbase-5
- qtmultimedia-5
- qtscript
- qtsvg-5
- snorenotify
- sonnet
- zlib))
- (home-page "https://quassel-irc.org/")
- (synopsis "Distributed IRC client")
- (description "Quassel is a distributed IRC client, meaning that one or more
- clients can attach to and detach from the central core. It resembles the
- popular combination of screen and a text-based IRC client such as WeeChat or
- irssi, but graphical.")
- (license (list license:gpl2 license:gpl3)))) ;; dual licensed
- (define-public irssi
- (package
- (name "irssi")
- (version "1.4.4")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/irssi/irssi/"
- "releases/download/" version "/irssi-"
- version ".tar.xz"))
- (sha256
- (base32
- "1bby23mn7318dmxf8aw9ahs6j4mbc0ilm4swji4m8ixiqz49xzpy"))))
- (build-system gnu-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'configure
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (setenv "CONFIG_SHELL" (which "bash"))
- (invoke "./configure"
- (string-append "--prefix=" out)
- (string-append "--enable-true-color")
- (string-append "--with-proxy")
- (string-append "--with-socks")))))
- (add-before 'check 'set-home
- (lambda _
- (setenv "HOME" (getcwd)))))))
- (inputs
- (list glib ncurses openssl perl utf8proc))
- (native-inputs
- (list pkg-config))
- (home-page "https://irssi.org/")
- (synopsis "Extensible terminal-based IRC client")
- (description
- "Irssi is a text terminal-based @acronym{IRC, Internet relay chat} client.
- It is completely themable and extensible through Perl scripts, of which many
- have already been written by the community.
- Plug-ins add support for other protocols like @acronym{SILC, Secure Internet Live
- Conferencing} and @acronym{ICB, Internet Citizen's Band}.")
- (license license:gpl2+)))
- (define-public weechat
- (package
- (name "weechat")
- (version "3.8")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://weechat.org/files/src/weechat-"
- version ".tar.xz"))
- (sha256
- (base32
- "0a5zfkqqdkya111rl2gpwlbfala0305qry9cdz2r1h7q0316bjzp"))))
- (build-system cmake-build-system)
- (outputs '("out" "doc"))
- (native-inputs
- `(("gettext-minimal" ,gettext-minimal)
- ("pkg-config" ,pkg-config)
- ,@(if (target-x86?)
- `(("ruby-asciidoctor" ,ruby-asciidoctor))
- '())))
- (inputs
- (list aspell
- curl
- gnutls
- libgcrypt
- ncurses
- zlib
- (list zstd "lib")
- ;; Scripting language plug-ins.
- guile-3.0
- lua-5.1
- perl
- python
- ruby
- tcl))
- (arguments
- `(#:configure-flags
- (list "-DENABLE_PHP=OFF"
- ,@(if (target-x86?)
- '("-DENABLE_MAN=ON"
- "-DENABLE_DOC=ON")
- '()))
- #:phases
- (modify-phases %standard-phases
- ,@(if (target-x86?)
- '((add-after 'install 'move-doc
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (doc (assoc-ref outputs "doc"))
- (from (string-append out "/share/doc/weechat"))
- (to (string-append doc "/share/doc/weechat")))
- (mkdir-p (string-append doc "/share/doc"))
- (rename-file from to)))))
- '()))))
- (synopsis "Extensible chat client")
- (description "WeeChat (Wee Enhanced Environment for Chat) is an
- @dfn{Internet Relay Chat} (IRC) client, which is designed to be light and fast.
- The client uses a curses frontend, and there are remote interfaces for Web,
- Qt, Android, and Emacs.
- Everything in WeeChat can be done with the keyboard, though it also supports
- using a mouse. It is customizable and extensible with plugins and scripts.")
- (home-page "https://weechat.org/")
- (license license:gpl3)))
- (define-public srain
- (package
- (name "srain")
- (version "1.5.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/SrainApp/srain")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1qswvhx1s90jbsdx5znbc478v2ix3g0p6qm97cj7zzl0kx5kd780"))))
- (build-system meson-build-system)
- (arguments
- `(#:tests? #f ;there are no tests
- #:glib-or-gtk? #t))
- (native-inputs
- `(("gettext" ,gettext-minimal)
- ("glib:bin" ,glib "bin")
- ("pkg-config" ,pkg-config)
- ("python" ,python-wrapper)
- ("python-sphinx" ,python-sphinx)))
- (inputs
- (list glib-networking
- gsettings-desktop-schemas
- gtk+
- libconfig
- libsecret
- libsoup-minimal-2
- openssl))
- (home-page "https://srain.im")
- (synopsis "Modern IRC client written in GTK")
- (description
- "Srain is an IRC client written in GTK. It aims to be modern and easy to
- use while still remaining useful to power users. It also has partial support
- for the IRCv3 protocol.")
- (license license:gpl3+)))
- (define-public ircii
- (package
- (name "ircii")
- (version "20210314")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://ircii.warped.com/"
- name "-" version ".tar.gz"))
- (sha256
- (base32
- "04jczayv1vdn21fcf5zkfaa98sy7d6ydrv2sns2i67gvya2z28j3"))))
- (build-system gnu-build-system)
- ;; TODO: We should package a small socks4/5 library/server to configure
- ;; ircii with socks client. `ghc-socks' pulls in lots of haskell, which
- ;; is too big.
- (arguments
- `(#:tests? #f
- #:configure-flags (list
- "--enable-ipv6"
- "--with-emacs-meta-keys"
- (string-append "--with-openssl="
- (assoc-ref %build-inputs "openssl")))
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-bsdinstall-absolute-path-bins
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "bsdinstall"
- (("/bin/strip") "strip")
- (("/bin/cp") "cp")
- (("/bin/chmod") "chmod")
- (("/etc/chown") "chown")
- (("/bin/chgrp") "chgrp")
- (("/bin/mkdir") "mkdir")
- (("/bin/rm") "rm")
- (("/bin/mv") "mv")))))))
- (inputs
- (list ncurses openssl))
- (native-inputs
- (list pkg-config perl))
- (home-page "http://www.eterna.com.au/ircii/")
- (synopsis "Terminal-based IRC and ICB client")
- (description
- "ircII is a terminal based IRC and ICB client for UNIX systems.")
- (license license:bsd-3)))
- (define-public catgirl
- (package
- (name "catgirl")
- (version "2.1")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://git.causal.agency/catgirl/snapshot/"
- name "-" version ".tar.gz"))
- (sha256
- (base32
- "13pfphcfkdzqfb4x7w21xp6rnmg3ix9f39mpqmxxzg15ys1gp2x6"))))
- (build-system gnu-build-system)
- (arguments
- `(#:tests? #f ; no tests
- #:make-flags (list (string-append "PREFIX=" %output)
- ,(string-append "CC=" (cc-for-target)))))
- (native-inputs
- (list universal-ctags pkg-config))
- (inputs
- (list libressl ncurses))
- (home-page "https://git.causal.agency/catgirl")
- (synopsis "TLS-only terminal IRC client")
- (description
- "@command{catgirl} is a TLS-only terminal IRC client.
- Notable features include:
- @itemize
- @item Tab complete: most recently seen or mentioned nicks are completed first.
- Commas are inserted between multiple nicks.
- @item Prompt: the prompt clearly shows whether input will be interpreted as a
- command or sent as a message.
- @item Split scroll: keeps the latest messages in view while scrolling.
- @item URL detection: recent URLs from a particular user or matching a
- substring can be opened or copied.
- @item Nick coloring: color generation based on usernames remains stable across
- nick changes. Mentions of users in messages are colored.
- @item Topic diffing: the modified portion of a channel topic change is
- highlighted.
- @end itemize")
- (license license:gpl3+)))
- (define-public ii
- (package
- (name "ii")
- (version "2.0")
- (source (origin
- (method url-fetch)
- (uri (string-append "http://dl.suckless.org/tools/"
- name "-" version ".tar.gz"))
- (sha256
- (base32
- "0ns2wpzkk7qzhv7addgr0w5as0m7jwag5nxai2dr61wc436syrsg"))))
- (build-system gnu-build-system)
- (arguments
- (list #:tests? #f ; no tests
- #:make-flags
- #~(list (string-append "PREFIX=" #$output)
- (string-append "CC=" #$(cc-for-target)))
- #:phases
- #~(modify-phases %standard-phases
- (delete 'configure)))) ; no configure script
- (home-page "https://tools.suckless.org/ii/")
- (synopsis "FIFO and file system based IRC client")
- (description
- "ii (Irc it) is a minimalist FIFO and file system based IRC client.")
- (license license:expat)))
- (define-public sic
- (package
- (name "sic")
- (version "1.2")
- (source (origin
- (method url-fetch)
- (uri (string-append "http://dl.suckless.org/tools/"
- name "-" version ".tar.gz"))
- (sha256
- (base32
- "11aiavxp44yayibc58bvimi8mrxvbw1plbci8cnbl4syk42zj1xc"))))
- (build-system gnu-build-system)
- (arguments
- `(#:tests? #f ; no tests
- #:make-flags (list ,(string-append "CC=" (cc-for-target))
- (string-append "PREFIX=" %output))
- #:phases
- (modify-phases %standard-phases
- (delete 'configure)))) ; no configure
- (home-page "https://tools.suckless.org/sic/")
- (synopsis "Simple IRC client")
- (description
- "sic is a simple IRC client, even more minimalistic than ii.")
- (license license:expat)))
- (define-public kirc
- (package
- (name "kirc")
- (version "0.3.2")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/mcpcpc/kirc")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1ighpinss3k6xyqk05wrs76wvp2ahhh0jkkg8h7bhg66b14fsws9"))))
- (build-system gnu-build-system)
- (arguments
- `(#:tests? #f ; no tests
- #:make-flags
- (list (string-append "CC=" ,(cc-for-target))
- (string-append "PREFIX=" %output))
- #:phases
- (modify-phases %standard-phases
- (delete 'configure)))) ; No ./configure script
- (synopsis "IRC client written in POSIX C99")
- (description "Kirc is an Internet Relay Chat (IRC) client. It includes
- support for Simple Authentication and Security Layer (SASL), the
- client-to-client (CTCP) protocol, simple chat history logging, synchronous
- message handling, multi-channel joining at server connection, full support for
- all RFC 2812 commands, and customized color scheme definitions.")
- (home-page "http://kirc.io/index.html")
- (license license:expat)))
- (define-public limnoria
- (package
- (name "limnoria")
- (version "2019.11.22")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "limnoria" version))
- (sha256
- (base32 "0853xk1ps3v6lkmfx50wv56vynnzpl84v66hxnhl8i34zl36kk3c"))))
- (build-system python-build-system)
- (inputs
- (list python-pytz
- python-chardet
- python-dateutil
- python-gnupg
- python-feedparser
- python-sqlalchemy
- python-socksipy-branch
- python-ecdsa))
- (native-inputs
- (list python-mock))
- ;; Despite the existence of a test folder there is no test phase.
- ;; We need to package https://github.com/ProgVal/irctest and write
- ;; our own testphase.
- (arguments
- `(#:tests? #f))
- (home-page "https://github.com/ProgVal/Limnoria")
- (synopsis "Modified version of Supybot (an IRC bot and framework)")
- (description
- "Modified version of Supybot with Python 3 and IRCv3 support,
- embedded web server, translations (fr, fi, it, hu, de), and many
- other enhancements and bug fixes.")
- (license license:bsd-3)))
- (define-public epic5
- (package
- (name "epic5")
- (version "2.0.1")
- (source (origin
- (method url-fetch)
- (uri (string-append "http://ftp.epicsol.org/pub/"
- "epic/EPIC5-PRODUCTION/"
- name "-" version ".tar.xz"))
- (sha256
- (base32
- "1ap73d5f4vccxjaaq249zh981z85106vvqmxfm4plvy76b40y9jm"))))
- (build-system gnu-build-system)
- (arguments
- `(#:test-target "test"
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-perl
- (lambda _
- (substitute* "regress/crash-irc"
- (("perl5") (which "perl")))
- #t))
- (add-after 'unpack 'patch-bsdinstall
- ;; If we just remove /bin/ some part of the bsdinstall breaks.
- ;; Furthermore bsdinstalls has a reference to /etc/chmod here, which
- ;; means if we leave /etc/ in, install fails.
- (lambda _
- (substitute* "bsdinstall"
- (("/bin/strip") "strip")
- (("/bin/cp") "cp")
- (("/bin/chmod") "chmod")
- (("/bin/chgrp") "chgrp")
- (("/bin/mkdir") "mkdir")
- (("/bin/rm") "rm")
- (("/bin/mv") "mv")
- (("/etc/") ""))
- #t))
- (replace 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- ;; The tarball uses a very old version of autconf. It does not
- ;; understand extra flags like `--enable-fast-install', so
- ;; we need to invoke it with just what it understands.
- (let ((out (assoc-ref outputs "out")))
- ;; 'configure' doesn't understand '--host'.
- ,@(if (%current-target-system)
- `((setenv "CHOST" ,(%current-target-system)))
- '())
- (setenv "CONFIG_SHELL" (which "bash"))
- (setenv "SHELL" (which "bash"))
- (invoke "./configure"
- (string-append "--prefix=" out)
- "--with-ipv6" "--with-libarchive"
- ;; We use libressl because openssl does not come
- ;; with the lib/libssl.a which is needed for epic5.
- ;; XXX: No matter which implementation is chosen,
- ;; epic5 fails to connect to tls ports of roundrobin
- ;; irc networks. This however is believed to be an
- ;; protocol issue at epic5 related to ircd.
- (string-append "--with-ssl="
- (assoc-ref %build-inputs "libressl"))
- (string-append "--with-tcl="
- (assoc-ref %build-inputs "tcl")
- "/lib/tclConfig.sh"))))))))
- (inputs
- (list libressl
- ncurses
- libarchive ; CHANGELOG: "Support for loading zip files"
- perl
- tcl
- ruby))
- (native-inputs
- (list pkg-config))
- (home-page "http://epicsol.org")
- (synopsis "Epic5 IRC Client")
- (description
- "EPIC is a IRC client that has been under active development for
- over 20 years. It is stable and mature, and offers an excellent ircII
- interface for those who are accustomed to the ircII way of doing things.")
- (license (list license:bsd-3
- license:isc
- license:bsd-4
- ;; The epic license is equal to the standard three-clause
- ;; BSD license except that you are not permitted to remove the
- ;; "Redistribution is permitted" clause of the license if you
- ;; distribute binaries.
- (license:non-copyleft "http://epicsol.org/copyright")))))
- (define-public go-gopkg-in-irc-v3
- (package
- (name "go-gopkg-in-irc-v3")
- (version "3.1.4")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://gopkg.in/irc.v3")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0f2vv947yf9ygy8ylwqkd9yshybfdsbsp9pffjyvm7l7rnq5da60"))))
- (build-system go-build-system)
- (arguments
- '(;; TODO 3 tests fail because of missing files
- ;; https://paste.sr.ht/~whereiseveryone/784d068887a65c1b869caa7d7c2077d28a2b2187
- #:tests? #f
- #:import-path "gopkg.in/irc.v3" #:unpack-path "gopkg.in/irc.v3"))
- (propagated-inputs
- `(("go-gopkg-in-yaml-v2" ,go-gopkg-in-yaml-v2)
- ("go-github-com-stretchr-testify" ,go-github-com-stretchr-testify)))
- (home-page "https://gopkg.in/irc.v3")
- (synopsis "Low-level IRC library for Go")
- (description "Package irc provides a simple IRC library meant as a
- building block for other projects.")
- (license license:expat)))
- (define-public chathistorysync
- (package
- (name "chathistorysync")
- (version "0.2.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://git.sr.ht/~emersion/chathistorysync")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "03dxr178wnicggx0k95wvyzgyk4s4g0adbi2z0md517a5qd1lh23"))))
- (build-system go-build-system)
- (arguments
- (list #:import-path "git.sr.ht/~emersion/chathistorysync"
- #:install-source? #f ; chathistorysync is an end-user application.
- #:phases
- #~(modify-phases %standard-phases
- (add-after 'build 'doc
- (lambda _
- (with-directory-excursion
- "src/git.sr.ht/~emersion/chathistorysync"
- (invoke "sh" "-c"
- "scdoc <chathistorysync.1.scd >chathistorysync.1"))))
- (add-after 'install 'install-doc
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out")))
- (with-directory-excursion
- "src/git.sr.ht/~emersion/chathistorysync"
- (install-file
- "chathistorysync.1"
- (string-append out "/share/man/man1")))))))))
- (inputs
- (list go-golang-org-x-sys
- go-golang-org-x-term
- go-golang-org-x-crypto
- go-gopkg-in-irc-v3))
- (native-inputs (list scdoc))
- (home-page "https://git.sr.ht/~emersion/chathistorysync")
- (synopsis "Synchronization tool for IRC chat history")
- (description
- "This package provides a synchronization tool for IRC chat history.")
- (license license:agpl3)))
- (define-public litterbox
- (package
- (name "litterbox")
- (version "1.9")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "https://git.causal.agency/litterbox/snapshot/litterbox-"
- version ".tar.gz"))
- (sha256
- (base32 "1ag5x7h71pxjaaf4b561rwdqr05zzywkc0p3jf2yhg3lbjkjrc7z"))))
- (build-system gnu-build-system)
- (arguments
- `(#:tests? #f ; There are no tests.
- #:make-flags
- (list
- (string-append "CC=" ,(cc-for-target))
- (string-append "PREFIX=" %output))))
- (native-inputs
- (list pkg-config universal-ctags))
- (inputs
- (list libressl sqlite))
- (home-page "https://code.causal.agency/june/litterbox")
- (synopsis "TLS-only IRC logger")
- (description
- "@command{litterbox} is a TLS-only IRC logger. It logs
- events from IRC in a SQLite database, indexing messages for full-text
- search. It is intended for use with the IRC bouncer @command{pounce},
- but can also be used independently as a logging bot.")
- (license license:gpl3+)))
- (define-public inspircd
- (package
- (name "inspircd")
- (version "3.12.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/inspircd/inspircd")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0xlfs269iaw7dfryzl6vjzqsn2g4nqh6kpf5xfgk3zbjhqaczknx"))))
- (build-system gnu-build-system)
- (arguments
- (list #:configure-flags
- #~(map (lambda (module)
- (string-append "--enable-extras=" module))
- '("m_argon2.cpp"
- "m_geo_maxmind.cpp"
- "m_ldap.cpp"
- "m_mysql.cpp"
- "m_pgsql.cpp"
- "m_regex_pcre.cpp"
- "m_regex_posix.cpp"
- "m_regex_stdlib.cpp"
- "m_regex_re2.cpp"
- "m_regex_tre.cpp"
- "m_sqlite3.cpp"
- "m_ssl_gnutls.cpp"
- "m_ssl_openssl.cpp"
- "m_ssl_mbedtls.cpp"
- "m_sslrehashsignal.cpp"))
- #:tests? #f ; XXX figure out later
- #:phases
- #~(modify-phases %standard-phases
- (add-before 'configure 'module-configure
- (lambda* (#:key configure-flags #:allow-other-keys)
- (apply invoke "./configure"
- configure-flags)))
- (replace 'configure
- (lambda _
- (let ((lib (string-append #$output "/lib/"))
- (bin (string-append #$output "/bin/"))
- (etc (string-append #$output "/etc/"))
- (name "inspircd"))
- (invoke "./configure"
- (string-append "--prefix=" lib name)
- (string-append "--binary-dir=" bin)
- (string-append "--module-dir=" lib name "/modules/")
- (string-append "--config-dir=" etc name))))))))
- (native-inputs
- (list pkg-config))
- (inputs
- (list argon2
- gnutls
- libmaxminddb
- mbedtls-apache
- (list mariadb "dev")
- openldap
- openssl
- `(,pcre "bin")
- perl
- postgresql
- re2
- sqlite
- tre))
- (synopsis "Modular IRC server written in C++")
- (description "InspIRCd is a modular Internet Relay Chat
- server written in C++ for Unix-like operating systems.")
- (home-page "https://www.inspircd.org/")
- (license license:gpl2)))
|