PKGBUILD 1.9 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849
  1. # Maintainer: bill-auger <bill-auger@programmer.net>
  2. pkgname=calamares
  3. pkgver=3.1.0
  4. pkgrel=1
  5. pkgdesc='Distribution-independent installer framework'
  6. arch=('i686' 'x86_64')
  7. license=(GPL)
  8. url="https://github.com/calamares"
  9. license=('LGPL')
  10. depends=( 'boost-libs' 'dmidecode' 'gptfdisk' 'hwinfo' 'kconfig' 'kcoreaddons' 'ki18n'
  11. 'kparts' 'kpmcore' 'polkit-qt5' 'python' 'squashfs-tools' 'solid' 'qt5ct'
  12. 'qt5-styleplugins' 'qt5-svg' 'yaml-cpp' )
  13. makedepends=( 'extra-cmake-modules' 'qt5-tools' 'git' 'boost' )
  14. backup=( 'usr/share/calamares/modules/bootloader.conf'
  15. 'usr/share/calamares/modules/displaymanager.conf'
  16. 'usr/share/calamares/modules/initcpio.conf'
  17. 'usr/share/calamares/modules/unpackfs.conf' )
  18. _git_tag="${pkgver}-parabola-alpha1"
  19. source=("https://notabug.org/bill-auger/calamares/archive/v${_git_tag}.tar.gz")
  20. sha256sums=('6ae55f567d5eafdb781dc84988dec184637fa7cf8bd55d7a2157b2d920880d52')
  21. build() {
  22. cd ${srcdir}/calamares
  23. mkdir -p build
  24. cd build
  25. cmake -DCMAKE_BUILD_TYPE=Debug \
  26. -DCMAKE_INSTALL_PREFIX=/usr \
  27. -DCMAKE_INSTALL_LIBDIR=lib \
  28. -DWITH_CRASHREPORTER=OFF \
  29. -DSKIP_MODULES="dracut dracutlukscfg dummycpp dummyprocess dummypython \
  30. dummypythonqt grubcfg initramfs initramfscfg \
  31. interactiveterminal license luksbootkeyfile \
  32. luksopenswaphookcfg plymouthcfg removeuser webview" ..
  33. }
  34. package() {
  35. cd ${srcdir}/calamares/build
  36. make DESTDIR="$pkgdir" install
  37. # install -Dm644 "branding/parabola/squid.png" "$pkgdir/usr/share/icons/hicolor/scalable/apps/calamares.svg"
  38. # install -Dm644 "../data/calamares.desktop" "$pkgdir/usr/share/applications/calamares.desktop"
  39. }