default.nix 1.1 KB

123456789101112131415161718192021222324252627282930313233343536373839
  1. { stdenv, fetchgit, cmake, boost, gmp, mpfr, libedit, python
  2. , texinfo, gnused }:
  3. let
  4. rev = "20141005";
  5. in
  6. stdenv.mkDerivation {
  7. name = "ledger-3.1.0.${rev}";
  8. src = builtins.filterSource (path: type: type != "unknown") ./.;
  9. buildInputs = [ cmake boost gmp mpfr libedit python texinfo gnused ];
  10. enableParallelBuilding = true;
  11. # Skip byte-compiling of emacs-lisp files because this is currently
  12. # broken in ledger...
  13. postInstall = ''
  14. mkdir -p $out/share/emacs/site-lisp/
  15. cp -v "$src/lisp/"*.el $out/share/emacs/site-lisp/
  16. '';
  17. meta = {
  18. homepage = "http://ledger-cli.org/";
  19. description = "A double-entry accounting system with a command-line reporting interface";
  20. license = "BSD";
  21. longDescription = ''
  22. Ledger is a powerful, double-entry accounting system that is accessed
  23. from the UNIX command-line. This may put off some users, as there is
  24. no flashy UI, but for those who want unparalleled reporting access to
  25. their data, there really is no alternative.
  26. '';
  27. platforms = stdenv.lib.platforms.all;
  28. maintainers = with stdenv.lib.maintainers; [ simons the-kenny jwiegley ];
  29. };
  30. }