rules 1.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546
  1. #! /usr/bin/make -f
  2. #
  3. # debian/rules
  4. # Part of Debian ‘dput’ package.
  5. #
  6. # This is free software, and you are welcome to redistribute it under
  7. # certain conditions; see the end of this file for copyright
  8. # information, grant of license, and disclaimer of warranty.
  9. PACKAGE_NAME = dput
  10. export LC_ALL := C.UTF-8
  11. export PYTHONIOENCODING := utf-8
  12. package_share_dir = /usr/share/${PACKAGE_NAME}
  13. export PYBUILD_INSTALL_ARGS ?= \
  14. --install-lib=${package_share_dir}/ \
  15. --install-scripts=${package_share_dir}/
  16. %:
  17. dh $@ --with=bash-completion,python2 --buildsystem=pybuild
  18. override_dh_clean:
  19. dh_clean
  20. make clean
  21. override_dh_installman:
  22. dh_installman --language=C
  23. # Copyright © 2015–2016 Ben Finney <bignose@debian.org>
  24. #
  25. # This is free software: you may copy, modify, and/or distribute this work
  26. # under the terms of the GNU General Public License as published by the
  27. # Free Software Foundation; version 2 of that license or any later version.
  28. # No warranty expressed or implied. See the file ‘LICENSE.GPL-2’ for details.
  29. # Local variables:
  30. # coding: utf-8
  31. # mode: make
  32. # End:
  33. # vim: fileencoding=utf-8 filetype=make :