control 3.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485868788899091
  1. Source: python-lockfile
  2. Priority: optional
  3. Maintainer: Ben Finney <bignose@debian.org>
  4. Section: python
  5. Homepage: https://pypi.python.org/pypi/lockfile/
  6. Build-Depends:
  7. debhelper (>= 9~),
  8. dh-python,
  9. python3-setuptools,
  10. python3-pbr (>= 1.8),
  11. python3-nose,
  12. python3-sphinx,
  13. python3-all,
  14. python-setuptools,
  15. python-pbr (>= 1.8),
  16. python-nose,
  17. python-all
  18. Standards-Version: 3.9.8
  19. VCS-Git: https://notabug.org/bignose/debian_python-lockfile.git
  20. VCS-Browser: https://notabug.org/bignose/debian_python-lockfile/
  21. X-Python-Version: >= 2.7
  22. X-Python3-Version: >= 3.2
  23. Package: python-lockfile
  24. Architecture: all
  25. Depends:
  26. ${python:Depends},
  27. ${misc:Depends}
  28. Suggests: python-lockfile-doc
  29. Description: file locking library for Python — Python 2 library
  30. The ‘lockfile’ library exports a ‘LockFile’ class which provides a
  31. simple API for locking files.
  32. .
  33. The appropriate implementation for ‘LockFile’ is chosen automatically
  34. based on the OS capabilities for an atomic filesystem operation.
  35. These implementations are also available for explicit use as
  36. ‘LinkLockFile’ and ‘MkdirLockFile’.
  37. .
  38. Other back ends are possible with the same semantics. Examples
  39. included are:
  40. * ‘SQLiteLockFile’, using records in an SQLite database.
  41. * ‘PIDLockFile’, using the semantics of a Unix PID file.
  42. .
  43. Unlike other Python locking libraries (the Windows ‘msvcrt.locking’
  44. function, the Unix ‘fcntl.flock’, ‘fcntl.lockf’, and the deprecated
  45. ‘posixfile’ module), the API is identical across both Unix (including
  46. GNU/Linux and MacOS) and Windows platforms.
  47. .
  48. This package installs the Python 2 library.
  49. Package: python3-lockfile
  50. Architecture: all
  51. Depends:
  52. ${python3:Depends},
  53. ${misc:Depends}
  54. Suggests: python-lockfile-doc
  55. Description: file locking library for Python — Python 3 library
  56. The ‘lockfile’ library exports a ‘LockFile’ class which provides a
  57. simple API for locking files.
  58. .
  59. The appropriate implementation for ‘LockFile’ is chosen automatically
  60. based on the OS capabilities for an atomic filesystem operation.
  61. These implementations are also available for explicit use as
  62. ‘LinkLockFile’ and ‘MkdirLockFile’.
  63. .
  64. Other back ends are possible with the same semantics. Examples
  65. included are:
  66. * ‘SQLiteLockFile’, using records in an SQLite database.
  67. * ‘PIDLockFile’, using the semantics of a Unix PID file.
  68. .
  69. Unlike other Python locking libraries (the Windows ‘msvcrt.locking’
  70. function, the Unix ‘fcntl.flock’, ‘fcntl.lockf’, and the deprecated
  71. ‘posixfile’ module), the API is identical across both Unix (including
  72. GNU/Linux and MacOS) and Windows platforms.
  73. .
  74. This package installs the Python 3 library.
  75. Package: python-lockfile-doc
  76. Section: doc
  77. Architecture: all
  78. Depends:
  79. ${sphinxdoc:Depends},
  80. ${misc:Depends}
  81. Recommends: python-lockfile
  82. Description: file locking library for Python — documentation
  83. The ‘lockfile’ library exports a ‘LockFile’ class which provides a
  84. simple API for locking files.
  85. .
  86. This package installs the API documentation, in plain text and
  87. rendered as HTML.