smoke-python2 901 B

12345678910111213141516171819202122232425262728293031323334353637383940
  1. #! /bin/bash
  2. #
  3. # debian/tests/smoke-python2
  4. # Part of Debian ‘python-coverage’ package.
  5. #
  6. # Copyright © 2016 Ben Finney <bignose@debian.org>
  7. # This is free software; you may copy, modify, and/or distribute this work
  8. # under the terms of the Expat license as published by James Clark.
  9. # No warranty expressed or implied.
  10. #
  11. # Smoke test for package in Python 2 environments.
  12. set -o errexit
  13. set -o errtrace
  14. set -o nounset
  15. DISTRIBUTION_NAME=coverage
  16. MODULE_NAMES=(
  17. coverage
  18. )
  19. test_opts="--distribution=$DISTRIBUTION_NAME"
  20. for mod in ${MODULE_NAMES[@]} ; do
  21. # Accumulate the module names.
  22. test_opts="$test_opts --module=$mod"
  23. done
  24. for py in $(pyversions -i) ; do
  25. printf "Python command: %s\n" $py
  26. $py debian/tests/smoke_test.py $test_opts
  27. printf "\n"
  28. done
  29. # Local variables:
  30. # coding: utf-8
  31. # mode: shell-script
  32. # End:
  33. # vim: fileencoding=utf-8 filetype=sh :