control 1.3 KB

123456789101112131415161718192021222324252627282930313233343536
  1. Source: jquery-throttle-debounce
  2. Priority: optional
  3. Maintainer: Ben Finney <ben+debian@benfinney.id.au>
  4. Section: web
  5. Homepage: http://benalman.com/projects/jquery-throttle-debounce-plugin/
  6. Build-Depends:
  7. node-uglify,
  8. debhelper (>= 9~)
  9. Standards-Version: 3.9.8
  10. VCS-Git: https://notabug.org/bignose/debian_jquery-throttle-debounce.git
  11. VCS-Browser: https://notabug.org/bignose/debian_jquery-throttle-debounce/
  12. Package: libjs-jquery-throttle-debounce
  13. Architecture: all
  14. Depends:
  15. ${misc:Depends}
  16. Recommends:
  17. javascript-common
  18. Description: library of rate-limit wrappers for functions
  19. jQuery throttle / debounce allows you to rate-limit your functions in
  20. multiple useful ways:
  21. .
  22. * Passing a ‘delay’ and ‘callback’ to ‘$.throttle’ returns a new
  23. function that will execute no more than once every ‘delay’
  24. milliseconds.
  25. * Passing a ‘delay’ and ‘callback’ to ‘$.debounce’ returns a new
  26. function that will execute only once, coalescing multiple
  27. sequential calls into a single execution at either the very
  28. beginning or end.
  29. .
  30. jQuery isn’t actually required for this library, because nothing
  31. internal uses any jQuery methods or properties. jQuery is just used
  32. as a namespace under which these methods can exist.
  33. .
  34. This package installs the runtime library.