123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051 |
- #! /usr/bin/make -f
- #
- # debian/rules
- # Part of Debian ‘inform6-library’ package.
- #
- # Copyright © 2009–2016 Ben Finney <ben+debian@benfinney.id.au>
- #
- # This is free software; you may copy, modify, and/or distribute this
- # work under the terms of the GNU General Public License as published
- # by the Free Software Foundation; version 3 of that License or later.
- # No warranty expressed or implied.
- # See the file '/usr/share/common-licenses/GPL-3' for details.
- %:
- dh $@
- .PHONY: get-packaged-orig-source
- get-packaged-orig-source:
- $(uscan-download-source) --download-current-version
- # Policy §4.9 strongly recommends the ‘get-orig-source’ target:
- # “This target is optional, but providing it if possible is a good idea.”
- #
- # This target is an anomaly: per Policy §4.9, it fetches the *latest*
- # upstream source, regardless of this package's version. To fetch the
- # upstream source corresponding to this package's *declared* version
- # in ‘debian/changelog’, use ‘get-packaged-orig-source’ instead.
- .PHONY: get-orig-source
- get-orig-source:
- $(uscan-download-source)
- get-orig-source get-packaged-orig-source: http_proxy =
- get-orig-source get-packaged-orig-source: makefile_dir = $(abspath $(dir $(firstword ${MAKEFILE_LIST})))
- get-orig-source get-packaged-orig-source: package_dir = $(abspath $(dir ${makefile_dir}))
- define uscan-download-source
- uscan --noconf --verbose \
- --force-download \
- --rename \
- --destdir=$(CURDIR) \
- --check-dirname-level=0 ${package_dir}
- endef # uscan-download-source
- # Local variables:
- # mode: makefile
- # coding: utf-8
- # End:
- # vim: filetype=make fileencoding=utf-8 :
|