smoke-rpm 541 B

12345678910111213141516171819
  1. #!/bin/sh
  2. set -e
  3. set -x
  4. git init .
  5. git add .
  6. git commit -m"Smoketest" -a
  7. cat <<EOF >> ~/.rpmmacros
  8. %python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; import sys; sys.stdout.write(get_python_lib().replace('dist-', 'site-'))")
  9. %python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; import sys; sys.stdout.write(get_python_lib(1).replace('dist-', 'site-'))")
  10. EOF
  11. # Build an RPM of ourselfes
  12. gbp buildpackage-rpm --git-packaging-dir=packaging/ -bb --nodeps
  13. rm -r .git ~/.rpmmacros