Custom-configuration-of-Debian-package-build.patch 2.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566
  1. From: Tobias Quathamer <toddy@debian.org>
  2. Date: Mon, 26 Mar 2012 10:06:45 +0200
  3. Subject: Custom configuration of Debian package build
  4. ---
  5. config.params | 49 +++++++++++++++++++++++++++++++++++++++++++++++++
  6. 1 files changed, 49 insertions(+), 0 deletions(-)
  7. create mode 100644 config.params
  8. diff --git a/config.params b/config.params
  9. new file mode 100644
  10. index 0000000..97d45fb
  11. --- /dev/null
  12. +++ b/config.params
  13. @@ -0,0 +1,49 @@
  14. +# This file is read by configure and is used during the build of the
  15. +# Debian package.
  16. +
  17. +# Don't run configure interactively.
  18. +bsd_games_cfg_non_interactive=y
  19. +
  20. +# Install into here for building the package.
  21. +bsd_games_cfg_install_prefix=`pwd`/debian/bsdgames
  22. +
  23. +# Do not build or install these games:
  24. +bsd_games_cfg_no_build_dirs="dm banner fortune factor"
  25. +
  26. +# Keep huntd in /usr/sbin as it was in the past. I may
  27. +# change this later.
  28. +bsd_games_cfg_sbindir=/usr/sbin
  29. +
  30. +# Debian doesn't like cluttering up the /usr/*/games/ dirs too much,
  31. +# use a subdir. /var too.
  32. +bsd_games_cfg_usrlibdir=/usr/lib/games/bsdgames
  33. +bsd_games_cfg_sharedir=/usr/share/games/bsdgames
  34. +bsd_games_cfg_varlibdir=/var/games/bsdgames
  35. +
  36. +# Do not do chown now, we arn't running as root.
  37. +bsd_games_cfg_do_chown=n
  38. +
  39. +# Debian perfers symlinks for manpages.
  40. +bsd_games_cfg_use_dot_so=symlinks
  41. +
  42. +# I'll handle manpage compressing.
  43. +bsd_games_cfg_gzip_manpages=n
  44. +
  45. +# Policy says to use /usr/bin/pager by default.
  46. +bsd_games_cfg_pager=/usr/bin/pager
  47. +
  48. +# Always use the same wordlist for boggle, and don't use web2, it's too
  49. +# big. Instead, use the union of the wenglish and wbritish wordlists.
  50. +bsd_games_cfg_dictionary_src=`pwd`/temp-dictionary
  51. +
  52. +# Put it in /usr/share/games with the rest of the games data.
  53. +bsd_games_cfg_wtf_acronymfile=/usr/share/games/bsdgames/acronyms
  54. +
  55. +bsd_games_cfg_docdir=/usr/share/doc/bsdgames
  56. +
  57. +# Enable the use of hardening (and other) build flags
  58. +bsd_games_cfg_other_cflags="$(dpkg-buildflags --get CFLAGS) $(dpkg-buildflags --get CPPFLAGS)"
  59. +bsd_games_cfg_other_ldflags="$(dpkg-buildflags --get LDFLAGS)"
  60. +# This is for dab, the corresponding variable other_cxxflags does not
  61. +# exist, so append it to the "warning" flags
  62. +bsd_games_cfg_cxx_warning_flags="-Wall -W -Wpointer-arith -Wcast-align -Wcast-qual -Wwrite-strings $(dpkg-buildflags --get CXXFLAGS) $(dpkg-buildflags --get CPPFLAGS)"
  63. --