rules 560 B

1234567891011121314151617181920
  1. #!/usr/bin/make -f
  2. %:
  3. dh $@ --with python3
  4. debian/%: debian/%.in debian/debconf-helper.py debian/rules
  5. sed -e '/#DEBCONF_HELPER_PY#/ { ' -e 'r debian/debconf-helper.py' -ed -e' }' < $< > $@
  6. echo >> $@
  7. echo 'exit 0' >> $@
  8. echo '# Make lintian happy' >> $@
  9. sed -ne "s/^.*'\(apt.*\)' *: *_handle.*$$/db_get \1/p" < debian/debconf-helper.py >> $@
  10. chmod 444 $@
  11. override_dh_auto_clean:
  12. rm -f debian/postinst debian/config
  13. dh_auto_clean
  14. override_dh_auto_install: debian/postinst debian/config
  15. $(MAKE) install DESTDIR=$(shell pwd)/debian/apt-listchanges