sml.scm 2.9 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2017 Andy Patterson <ajpatter@uwaterloo.ca>
  3. ;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
  4. ;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
  5. ;;;
  6. ;;; This file is part of GNU Guix.
  7. ;;;
  8. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  9. ;;; under the terms of the GNU General Public License as published by
  10. ;;; the Free Software Foundation; either version 3 of the License, or (at
  11. ;;; your option) any later version.
  12. ;;;
  13. ;;; GNU Guix is distributed in the hope that it will be useful, but
  14. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  15. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  16. ;;; GNU General Public License for more details.
  17. ;;;
  18. ;;; You should have received a copy of the GNU General Public License
  19. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  20. (define-module (gnu packages sml)
  21. #:use-module (gnu packages lesstif)
  22. #:use-module (gnu packages libffi)
  23. #:use-module (gnu packages multiprecision)
  24. #:use-module (gnu packages xorg)
  25. #:use-module (guix build-system gnu)
  26. #:use-module (guix download)
  27. #:use-module (guix git-download)
  28. #:use-module ((guix licenses) #:prefix license:)
  29. #:use-module (guix packages))
  30. (define-public polyml
  31. (package
  32. (name "polyml")
  33. (version "5.7.1")
  34. (source (origin
  35. (method git-fetch)
  36. (uri (git-reference
  37. (url "https://github.com/polyml/polyml.git")
  38. (commit (string-append "v" version))))
  39. (file-name (git-file-name name version))
  40. (sha256
  41. (base32
  42. "0j0wv3ijfrjkfngy7dswm4k1dchk3jak9chl5735dl8yrl8mq755"))))
  43. (build-system gnu-build-system)
  44. (inputs
  45. `(("gmp" ,gmp)
  46. ("lesstif" ,lesstif)
  47. ("libffi" ,libffi)
  48. ("libx11" ,libx11)
  49. ("libxt" ,libxt)))
  50. (arguments
  51. '(#:configure-flags
  52. (list "--with-system-libffi=yes"
  53. "--with-x=yes"
  54. "--with-threads=yes"
  55. "--with-gmp=yes")
  56. #:phases
  57. (modify-phases %standard-phases
  58. (add-after 'build 'build-compiler
  59. (lambda* (#:key make-flags parallel-build? #:allow-other-keys)
  60. (define flags
  61. (if parallel-build?
  62. (cons (format #f "-j~d" (parallel-job-count))
  63. make-flags)
  64. make-flags))
  65. (apply system* "make" (append flags (list "compiler"))))))))
  66. (home-page "http://www.polyml.org/")
  67. (synopsis "Standard ML implementation")
  68. (description "Poly/ML is a Standard ML implementation. It is fully
  69. compatible with the ML97 standard. It includes a thread library, a foreign
  70. function interface, and a symbolic debugger.")
  71. ;; Some source files specify 'or any later version'; some don't
  72. (license
  73. (list license:lgpl2.1
  74. license:lgpl2.1+))))