lighting.scm 3.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2016 John J. Foerch <jjfoerch@earthlink.net>
  3. ;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
  4. ;;;
  5. ;;; This file is part of GNU Guix.
  6. ;;;
  7. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  8. ;;; under the terms of the GNU General Public License as published by
  9. ;;; the Free Software Foundation; either version 3 of the License, or (at
  10. ;;; your option) any later version.
  11. ;;;
  12. ;;; GNU Guix is distributed in the hope that it will be useful, but
  13. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  14. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  15. ;;; GNU General Public License for more details.
  16. ;;;
  17. ;;; You should have received a copy of the GNU General Public License
  18. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  19. (define-module (gnu packages lighting)
  20. #:use-module (guix build-system gnu)
  21. #:use-module (guix download)
  22. #:use-module ((guix licenses) #:prefix license:)
  23. #:use-module (guix packages)
  24. #:use-module (gnu packages)
  25. #:use-module (gnu packages bison)
  26. #:use-module (gnu packages check)
  27. #:use-module (gnu packages compression)
  28. #:use-module (gnu packages gnunet)
  29. #:use-module (gnu packages flex)
  30. #:use-module (gnu packages libftdi)
  31. #:use-module (gnu packages libusb)
  32. #:use-module (gnu packages linux)
  33. #:use-module (gnu packages pkg-config)
  34. #:use-module (gnu packages protobuf))
  35. (define-public ola
  36. (package
  37. (name "ola")
  38. (version "0.10.7")
  39. (source (origin
  40. (method url-fetch)
  41. (uri (string-append
  42. "https://github.com/OpenLightingProject/ola/releases/download/"
  43. version "/ola-" version ".tar.gz"))
  44. (patches (search-patches "ola-readdir-r.patch"))
  45. (sha256
  46. (base32
  47. "181imc9qkjm2m1iwrb5ixsckx893nc6qwjfzacsjlqp0jlnj8rca"))))
  48. (build-system gnu-build-system)
  49. (native-inputs
  50. `(("bison" ,bison)
  51. ("cppunit" ,cppunit)
  52. ("flex" ,flex)
  53. ("pkg-config" ,pkg-config)))
  54. (inputs
  55. `(("libftdi" ,libftdi)
  56. ("libmicrohttpd" ,libmicrohttpd)
  57. ("libusb" ,libusb)
  58. ("libuuid" ,util-linux)
  59. ("zlib" ,zlib)))
  60. (propagated-inputs
  61. ;; Ola 0.10.5 only supports protobuf 2.x, and building it with 3.x breaks.
  62. ;; XXX Remove protobuf-2 when it is no longer needed.
  63. `(("protobuf" ,protobuf-2))) ;; for pkg-config --libs libola
  64. (arguments
  65. `(;; G++ >= 4.8 macro expansion tracking requires lots of memory, causing
  66. ;; build to fail on low memory systems. We disable that with the
  67. ;; following configure flags.
  68. #:configure-flags (list "CXXFLAGS=-ftrack-macro-expansion=0")))
  69. (synopsis "Framework for controlling entertainment lighting equipment")
  70. (description "The Open Lighting Architecture is a framework for lighting
  71. control information. It supports a range of protocols and over a dozen USB
  72. devices. It can run as a standalone service, which is useful for converting
  73. signals between protocols, or alternatively using the OLA API, it can be used
  74. as the backend for lighting control software. OLA runs on many different
  75. platforms including ARM, which makes it a perfect fit for low cost Ethernet to
  76. DMX gateways.")
  77. (home-page "https://www.openlighting.org/ola")
  78. (license license:lgpl2.1+)))