libunwind.scm 2.2 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
  3. ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
  4. ;;;
  5. ;;; This file is part of GNU Guix.
  6. ;;;
  7. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  8. ;;; under the terms of the GNU General Public License as published by
  9. ;;; the Free Software Foundation; either version 3 of the License, or (at
  10. ;;; your option) any later version.
  11. ;;;
  12. ;;; GNU Guix is distributed in the hope that it will be useful, but
  13. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  14. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  15. ;;; GNU General Public License for more details.
  16. ;;;
  17. ;;; You should have received a copy of the GNU General Public License
  18. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  19. (define-module (gnu packages libunwind)
  20. #:use-module (guix packages)
  21. #:use-module (gnu packages)
  22. #:use-module (guix download)
  23. #:use-module (guix build-system gnu)
  24. #:use-module (guix licenses))
  25. (define-public libunwind
  26. (package
  27. (name "libunwind")
  28. (version "1.2.1")
  29. (source (origin
  30. (method url-fetch)
  31. (uri (string-append "mirror://savannah/libunwind/libunwind-"
  32. version ".tar.gz"))
  33. (sha256
  34. (base32
  35. "1jsslwkilwrsj959dc8b479qildawz67r8m4lzxm7glcwa8cngiz"))))
  36. (build-system gnu-build-system)
  37. (arguments
  38. ;; FIXME: As of glibc 2.25, we get 1 out of 34 test failures (2 are
  39. ;; expected to fail).
  40. ;; Report them upstream.
  41. '(#:tests? #f))
  42. (home-page "https://www.nongnu.org/libunwind")
  43. (synopsis "Determining the call chain of a program")
  44. (description
  45. "The primary goal of this project is to define a portable and efficient C
  46. programming interface (API) to determine the call-chain of a program. The API
  47. additionally provides the means to manipulate the preserved (callee-saved)
  48. state of each call-frame and to resume execution at any point in the
  49. call-chain (non-local goto). The API supports both local (same-process) and
  50. remote (across-process) operation. As such, the API is useful in a number of
  51. applications.")
  52. (license x11)))