gsasl.scm 4.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2012 Andreas Enge <andreas@enge.fr>
  3. ;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
  4. ;;; Copyright © 2017 Eric Bavier <bavier@member.fsf.org>
  5. ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
  6. ;;;
  7. ;;; This file is part of GNU Guix.
  8. ;;;
  9. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  10. ;;; under the terms of the GNU General Public License as published by
  11. ;;; the Free Software Foundation; either version 3 of the License, or (at
  12. ;;; your option) any later version.
  13. ;;;
  14. ;;; GNU Guix is distributed in the hope that it will be useful, but
  15. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  16. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  17. ;;; GNU General Public License for more details.
  18. ;;;
  19. ;;; You should have received a copy of the GNU General Public License
  20. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  21. (define-module (gnu packages gsasl)
  22. #:use-module (gnu packages)
  23. #:use-module (gnu packages compression)
  24. #:use-module (gnu packages libidn)
  25. #:use-module (gnu packages nettle)
  26. #:use-module (gnu packages kerberos)
  27. #:use-module (gnu packages tls)
  28. #:use-module ((guix licenses) #:prefix license:)
  29. #:use-module (guix packages)
  30. #:use-module (guix download)
  31. #:use-module (guix build-system gnu))
  32. (define-public libntlm
  33. (package
  34. (name "libntlm")
  35. (version "1.5")
  36. (source (origin
  37. (method url-fetch)
  38. (uri (string-append "https://www.nongnu.org/libntlm/releases/"
  39. "libntlm-" version ".tar.gz"))
  40. (sha256
  41. (base32
  42. "1gcvv7f9rggpxay81qv6kw5hr6gd4qiyzkbwhzz02fx9jvv9kmsk"))))
  43. (build-system gnu-build-system)
  44. (synopsis "Library that implements NTLM authentication")
  45. (description
  46. "Libntlm is a library that implements NTLM authentication.")
  47. (license license:lgpl2.1+)
  48. (home-page "https://www.nongnu.org/libntlm/")))
  49. (define-public gss
  50. (package
  51. (name "gss")
  52. (version "1.0.3")
  53. (source (origin
  54. (method url-fetch)
  55. (uri (string-append "mirror://gnu/gss/gss-" version
  56. ".tar.gz"))
  57. (sha256 (base32
  58. "1syyvh3k659xf1hdv9pilnnhbbhs6vfapayp4xgdcc8mfgf9v4gz"))))
  59. (build-system gnu-build-system)
  60. (inputs `(("nettle" ,nettle)
  61. ("shishi" ,shishi)
  62. ("zlib" ,zlib)))
  63. (synopsis "Generic Security Service library")
  64. (description
  65. "The GNU Generic Security Service provides a free implementation of the
  66. GSS-API specification. It provides a generic application programming
  67. interface for programs to access security services. Security services present
  68. a generic, GSS interface, with which the calling application interacts via
  69. this library, freeing the application developer from needing to know about
  70. the underlying security implementation.")
  71. (license license:gpl3+)
  72. (home-page "https://www.gnu.org/software/gss/")))
  73. (define-public gsasl
  74. (package
  75. (name "gsasl")
  76. (version "1.8.0")
  77. (source (origin
  78. (method url-fetch)
  79. (uri (string-append "mirror://gnu/gsasl/gsasl-" version
  80. ".tar.gz"))
  81. (sha256 (base32
  82. "1rci64cxvcfr8xcjpqc4inpfq7aw4snnsbf5xz7d30nhvv8n40ii"))
  83. (modules '((guix build utils)))
  84. (snippet
  85. '(begin
  86. ;; The gnulib test-lock test is prone to writer starvation
  87. ;; with our glibc@2.25, which prefers readers, so disable it.
  88. ;; The gnulib commit b20e8afb0b2 should fix this once
  89. ;; incorporated here.
  90. (substitute* "tests/Makefile.in"
  91. (("test-lock\\$\\(EXEEXT\\) ") ""))
  92. #t))))
  93. (build-system gnu-build-system)
  94. (inputs `(("libidn" ,libidn)
  95. ("libntlm" ,libntlm)
  96. ("gss" ,gss)
  97. ("zlib" ,zlib)))
  98. (propagated-inputs
  99. ;; Propagate GnuTLS because libgnutls.la reads `-lnettle', and Nettle is a
  100. ;; propagated input of GnuTLS.
  101. `(("gnutls" ,gnutls)))
  102. (synopsis "Simple Authentication and Security Layer library")
  103. (description
  104. "GNU SASL is an implementation of the Simple Authentication and
  105. Security Layer framework. On network servers such as IMAP or SMTP servers,
  106. SASL is used to handle client/server authentication. This package contains
  107. both a library and a command-line tool to access the library.")
  108. (license license:gpl3+)
  109. (home-page "https://www.gnu.org/software/gsasl/")))