cyrus-sasl.scm 2.9 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2013, 2014, 2015, 2017 Ludovic Courtès <ludo@gnu.org>
  3. ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
  4. ;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
  5. ;;;
  6. ;;; This file is part of GNU Guix.
  7. ;;;
  8. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  9. ;;; under the terms of the GNU General Public License as published by
  10. ;;; the Free Software Foundation; either version 3 of the License, or (at
  11. ;;; your option) any later version.
  12. ;;;
  13. ;;; GNU Guix is distributed in the hope that it will be useful, but
  14. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  15. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  16. ;;; GNU General Public License for more details.
  17. ;;;
  18. ;;; You should have received a copy of the GNU General Public License
  19. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  20. (define-module (gnu packages cyrus-sasl)
  21. #:use-module (gnu packages)
  22. #:use-module (gnu packages dbm)
  23. #:use-module (gnu packages kerberos)
  24. #:use-module (gnu packages tls)
  25. #:use-module ((guix licenses) #:prefix license:)
  26. #:use-module (guix packages)
  27. #:use-module (guix download)
  28. #:use-module (guix build-system gnu))
  29. (define-public cyrus-sasl
  30. (package
  31. (name "cyrus-sasl")
  32. (version "2.1.27")
  33. (source (origin
  34. (method url-fetch)
  35. (uri (list (string-append
  36. "https://cyrusimap.org/releases/cyrus-sasl-"
  37. version ".tar.gz")
  38. (string-append
  39. "ftp://ftp.cyrusimap.org/cyrus-sasl/cyrus-sasl-"
  40. version ".tar.gz")))
  41. (sha256 (base32
  42. "1m85zcpgfdhm43cavpdkhb1s2zq1b31472hq1w1gs3xh94anp1i6"))))
  43. (build-system gnu-build-system)
  44. (inputs `(("gdbm" ,gdbm)
  45. ("openssl" ,openssl)))
  46. (propagated-inputs
  47. `(;; cyrus-sasl.pc refers to -lkrb5, so propagate it.
  48. ("mit-krb5" ,mit-krb5)))
  49. (arguments
  50. '(#:configure-flags (list (string-append "--with-plugindir="
  51. (assoc-ref %outputs "out")
  52. "/lib/sasl2"))
  53. ;; The 'plugins' directory has shared source files, such as
  54. ;; 'plugin_common.c'. When building the shared libraries there, libtool
  55. ;; ends up doing "ln -s plugin_common.lo plugin_common.o", which can
  56. ;; fail with EEXIST when building things in parallel.
  57. #:parallel-build? #f))
  58. (synopsis "Simple Authentication Security Layer implementation")
  59. (description
  60. "SASL (Simple Authentication Security Layer) is an Internet
  61. standards-track method for remote computers to authenticate. The Cyrus SASL
  62. library makes supporting various SASL mechanisms easy for both client and
  63. server writers.")
  64. (license (license:non-copyleft "file://COPYING"
  65. "See COPYING in the distribution."))
  66. (home-page "https://cyrusimap.org/sasl/")))