calcurse.scm 2.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2014, 2015, 2017 Eric Bavier <bavier@member.fsf.org>
  3. ;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
  4. ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
  5. ;;;
  6. ;;; This file is part of GNU Guix.
  7. ;;;
  8. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  9. ;;; under the terms of the GNU General Public License as published by
  10. ;;; the Free Software Foundation; either version 3 of the License, or (at
  11. ;;; your option) any later version.
  12. ;;;
  13. ;;; GNU Guix is distributed in the hope that it will be useful, but
  14. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  15. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  16. ;;; GNU General Public License for more details.
  17. ;;;
  18. ;;; You should have received a copy of the GNU General Public License
  19. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  20. (define-module (gnu packages calcurse)
  21. #:use-module (guix packages)
  22. #:use-module (guix licenses)
  23. #:use-module (guix download)
  24. #:use-module (guix build-system gnu)
  25. #:use-module (gnu packages)
  26. #:use-module (gnu packages base)
  27. #:use-module (gnu packages ncurses))
  28. (define-public calcurse
  29. (package
  30. (name "calcurse")
  31. (version "4.3.0")
  32. (source
  33. (origin
  34. (method url-fetch)
  35. (uri (string-append "https://calcurse.org/files/calcurse-"
  36. version ".tar.gz"))
  37. (sha256
  38. (base32
  39. "16jzg0nasnxdlz23i121x41pq5kbxmjzk52c5d863rg117fc7v1i"))))
  40. (build-system gnu-build-system)
  41. (inputs `(("ncurses" ,ncurses)))
  42. (native-inputs `(("tzdata" ,tzdata-for-tests)))
  43. (arguments
  44. ;; The ical tests all want to create a ".calcurse" directory, and may
  45. ;; fail with "cannot create directory '.calcurse': File exists" if run
  46. ;; concurently.
  47. `(#:parallel-tests? #f
  48. ;; Since this tzdata is only used for tests and not referenced by the
  49. ;; built package, used the "fixed" obsolete version of tzdata and ensure
  50. ;; it does not sneak in to the closure.
  51. #:disallowed-references (,tzdata-for-tests)
  52. #:phases (modify-phases %standard-phases
  53. (add-before 'check 'check-setup
  54. (lambda* (#:key inputs #:allow-other-keys)
  55. (setenv "TZDIR" ;for test/ical-007.sh
  56. (string-append (assoc-ref inputs "tzdata")
  57. "/share/zoneinfo")))))))
  58. (home-page "https://www.calcurse.org")
  59. (synopsis "Text-based calendar and scheduling")
  60. (description
  61. "Calcurse is a text-based calendar and scheduling application. It helps
  62. keep track of events, appointments and everyday tasks. A configurable
  63. notification system reminds user of upcoming deadlines, and the curses based
  64. interface can be customized to suit user needs. All of the commands are
  65. documented within an online help system.")
  66. (license bsd-2)))