autogen.scm 3.0 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2013, 2014 Eric Bavier <bavier@member.fsf.org>
  3. ;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
  4. ;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
  5. ;;;
  6. ;;; This file is part of GNU Guix.
  7. ;;;
  8. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  9. ;;; under the terms of the GNU General Public License as published by
  10. ;;; the Free Software Foundation; either version 3 of the License, or (at
  11. ;;; your option) any later version.
  12. ;;;
  13. ;;; GNU Guix is distributed in the hope that it will be useful, but
  14. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  15. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  16. ;;; GNU General Public License for more details.
  17. ;;;
  18. ;;; You should have received a copy of the GNU General Public License
  19. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  20. (define-module (gnu packages autogen)
  21. #:use-module (guix packages)
  22. #:use-module (guix licenses)
  23. #:use-module (guix download)
  24. #:use-module (guix build-system gnu)
  25. #:use-module (gnu packages)
  26. #:use-module (gnu packages perl)
  27. #:use-module (gnu packages pkg-config)
  28. #:use-module (gnu packages base)
  29. #:use-module (gnu packages guile))
  30. (define-public autogen
  31. (package
  32. (name "autogen")
  33. (version "5.18.16")
  34. (source
  35. (origin
  36. (method url-fetch)
  37. (uri (string-append "mirror://gnu/autogen/rel" version
  38. "/autogen-" version ".tar.xz"))
  39. (sha256
  40. (base32 "16mlbdys8q4ckxlvxyhwkdnh1ay9f6g0cyp1kylkpalgnik398gq"))))
  41. (build-system gnu-build-system)
  42. (native-inputs `(("pkg-config" ,pkg-config)
  43. ("which" ,which)))
  44. (inputs `(("guile" ,guile-2.2)
  45. ("perl" ,perl))) ; for doc generator mdoc
  46. (arguments
  47. '(#:configure-flags
  48. ;; XXX Needed to build 5.18.16. ./configure fails without it:
  49. ;; “Something went wrong bootstrapping makefile fragments for
  50. ;; automatic dependency tracking. Try re-running configure with […]”
  51. (list "--disable-dependency-tracking")
  52. #:phases
  53. (modify-phases %standard-phases
  54. (add-before 'patch-source-shebangs 'patch-test-scripts
  55. (lambda _
  56. (let ((sh (which "sh")))
  57. (substitute*
  58. (append (find-files "agen5/test" "\\.test$")
  59. (find-files "autoopts/test" "\\.(test|in)$"))
  60. (("/bin/sh") sh))
  61. #t))))))
  62. (home-page "https://www.gnu.org/software/autogen/")
  63. (synopsis "Automated program generator")
  64. (description
  65. "AutoGen is a program to ease the maintenance of programs that contain
  66. large amounts of repetitive text. It automates the construction of these
  67. sections of the code, simplifying the task of keeping the text in sync. It
  68. also includes an add-on package called AutoOpts, which is specialized for the
  69. maintenance and documentation of program options.")
  70. (license gpl3+)))