1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980818283848586878889909192939495969798991001011021031041051061071081091101111121131141151161171181191201211221231241251261271281291301311321331341351361371381391401411421431441451461471481491501511521531541551561571581591601611621631641651661671681691701711721731741751761771781791801811821831841851861871881891901911921931941951961971981992002012022032042052062072082092102112122132142152162172182192202212222232242252262272282292302312322332342352362372382392402412422432442452462472482492502512522532542552562572582592602612622632642652662672682692702712722732742752762772782792802812822832842852862872882892902912922932942952962972982993003013023033043053063073083093103113123133143153163173183193203213223233243253263273283293303313323333343353363373383393403413423433443453463473483493503513523533543553563573583593603613623633643653663673683693703713723733743753763773783793803813823833843853863873883893903913923933943953963973983994004014024034044054064074084094104114124134144154164174184194204214224234244254264274284294304314324334344354364374384394404414424434444454464474484494504514524534544554564574584594604614624634644654664674684694704714724734744754764774784794804814824834844854864874884894904914924934944954964974984995005015025035045055065075085095105115125135145155165175185195205215225235245255265275285295305315325335345355365375385395405415425435445455465475485495505515525535545555565575585595605615625635645655665675685695705715725735745755765775785795805815825835845855865875885895905915925935945955965975985996006016026036046056066076086096106116126136146156166176186196206216226236246256266276286296306316326336346356366376386396406416426436446456466476486496506516526536546556566576586596606616626636646656666676686696706716726736746756766776786796806816826836846856866876886896906916926936946956966976986997007017027037047057067077087097107117127137147157167177187197207217227237247257267277287297307317327337347357367377387397407417427437447457467477487497507517527537547557567577587597607617627637647657667677687697707717727737747757767777787797807817827837847857867877887897907917927937947957967977987998008018028038048058068078088098108118128138148158168178188198208218228238248258268278288298308318328338348358368378388398408418428438448458468478488498508518528538548558568578588598608618628638648658668678688698708718728738748758768778788798808818828838848858868878888898908918928938948958968978988999009019029039049059069079089099109119129139149159169179189199209219229239249259269279289299309319329339349359369379389399409419429439449459469479489499509519529539549559569579589599609619629639649659669679689699709719729739749759769779789799809819829839849859869879889899909919929939949959969979989991000100110021003 |
- ;;; GNU Guix --- Functional package management for GNU
- ;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019 Andreas Enge <andreas@enge.fr>
- ;;; Copyright © 2013, 2015, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
- ;;; Copyright © 2016, 2017, 2018, 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
- ;;; Copyright © 2014, 2018 Mark H Weaver <mhw@netris.org>
- ;;; Copyright © 2016, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
- ;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
- ;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
- ;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
- ;;; Copyright © 2017, 2019 Eric Bavier <bavier@member.fsf.org>
- ;;;
- ;;; This file is part of GNU Guix.
- ;;;
- ;;; GNU Guix is free software; you can redistribute it and/or modify it
- ;;; under the terms of the GNU General Public License as published by
- ;;; the Free Software Foundation; either version 3 of the License, or (at
- ;;; your option) any later version.
- ;;;
- ;;; GNU Guix is distributed in the hope that it will be useful, but
- ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
- ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- ;;; GNU General Public License for more details.
- ;;;
- ;;; You should have received a copy of the GNU General Public License
- ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
- (define-module (gnu packages algebra)
- #:use-module (gnu packages)
- #:use-module (gnu packages autotools)
- #:use-module (gnu packages check)
- #:use-module (gnu packages compression)
- #:use-module (gnu packages cpp)
- #:use-module (gnu packages documentation)
- #:use-module (gnu packages ed)
- #:use-module (gnu packages flex)
- #:use-module (gnu packages fltk)
- #:use-module (gnu packages gl)
- #:use-module (gnu packages graphviz)
- #:use-module (gnu packages image)
- #:use-module (gnu packages java)
- #:use-module (gnu packages maths)
- #:use-module (gnu packages mpi)
- #:use-module (gnu packages multiprecision)
- #:use-module (gnu packages perl)
- #:use-module (gnu packages python)
- #:use-module (gnu packages readline)
- #:use-module (gnu packages shells)
- #:use-module (gnu packages tex)
- #:use-module (gnu packages texinfo)
- #:use-module (gnu packages xiph)
- #:use-module (gnu packages xorg)
- #:use-module (guix build-system ant)
- #:use-module (guix build-system gnu)
- #:use-module (guix build-system cmake)
- #:use-module (guix download)
- #:use-module (guix git-download)
- #:use-module ((guix licenses) #:prefix license:)
- #:use-module (guix packages)
- #:use-module (guix utils))
- (define-public mpfrcx
- (package
- (name "mpfrcx")
- (version "0.5")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "http://www.multiprecision.org/downloads/mpfrcx-"
- version ".tar.gz"))
- (sha256
- (base32
- "1s968480ymv6w0rnvfp9mxvx98hvi29fkvw8nk4ggzc6azxgwybs"))))
- (build-system gnu-build-system)
- (propagated-inputs
- `(("gmp" ,gmp)
- ("mpfr" ,mpfr)
- ("mpc" ,mpc))) ; Header files are included by mpfrcx.h.
- (synopsis "Arithmetic of polynomials over arbitrary precision numbers")
- (description
- "Mpfrcx is a library for the arithmetic of univariate polynomials over
- arbitrary precision real (mpfr) or complex (mpc) numbers, without control
- on the rounding. For the time being, only the few functions needed to
- implement the floating point approach to complex multiplication are
- implemented. On the other hand, these comprise asymptotically fast
- multiplication routines such as Toom–Cook and the FFT.")
- (license license:lgpl3+)
- (home-page "http://mpfrcx.multiprecision.org/")))
- (define-public cm
- (package
- (name "cm")
- (version "0.3")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "http://www.multiprecision.org/cm/download/cm-"
- version ".tar.gz"))
- (sha256
- (base32
- "1nf5kr0nqmhbzrsrinky18z0ighjpsmb5cr8zyg8jf04bfbyrfmc"))))
- (build-system gnu-build-system)
- (propagated-inputs
- `(("mpfrcx" ,mpfrcx)
- ("zlib" ,zlib))) ; Header files included from cm_common.h.
- (inputs
- `(("pari-gp" ,pari-gp)))
- (synopsis "CM constructions for elliptic curves")
- (description
- "The CM software implements the construction of ring class fields of
- imaginary quadratic number fields and of elliptic curves with complex
- multiplication via floating point approximations. It consists of libraries
- that can be called from within a C program and of executable command
- line applications.")
- (license license:gpl3+)
- (home-page "http://cm.multiprecision.org/")))
- (define-public fplll
- (package
- (name "fplll")
- (version "4.0.4")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "http://perso.ens-lyon.fr/damien.stehle/fplll/libfplll-"
- version ".tar.gz"))
- (sha256 (base32
- "1cbiby7ykis4z84swclpysrljmqhfcllpkcbll1m08rzskgb1a6b"))))
- (build-system gnu-build-system)
- (inputs `(("gmp" ,gmp)
- ("mpfr" ,mpfr)))
- (synopsis "Library for LLL-reduction of euclidean lattices")
- (description
- "fplll LLL-reduces euclidean lattices. Since version 3, it can also
- solve the shortest vector problem.")
- (license license:lgpl2.1+)
- (home-page "http://perso.ens-lyon.fr/damien.stehle/fplll/")))
- (define-public pari-gp
- (package
- (name "pari-gp")
- (version "2.11.1")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "https://pari.math.u-bordeaux.fr/pub/pari/unix/pari-"
- version ".tar.gz"))
- (sha256
- (base32
- "1jfax92jpydjd02fwl30r6b8kfzqqd6sm4yx94gidyz9lqjb7a94"))))
- (build-system gnu-build-system)
- (native-inputs
- `(("texlive" ,(texlive-union
- (list texlive-fonts-amsfonts
- texlive-latex-amsfonts)))))
- (inputs `(("gmp" ,gmp)
- ("libx11" ,libx11)
- ("perl" ,perl)
- ("readline" ,readline)))
- (arguments
- '(#:make-flags '("all")
- #:test-target "dobench"
- #:phases
- (modify-phases %standard-phases
- (replace 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- (invoke "./Configure"
- (string-append "--prefix="
- (assoc-ref outputs "out"))))))))
- (synopsis "PARI/GP, a computer algebra system for number theory")
- (description
- "PARI/GP is a widely used computer algebra system designed for fast
- computations in number theory (factorisations, algebraic number theory,
- elliptic curves...), but it also contains a large number of other useful
- functions to compute with mathematical entities such as matrices,
- polynomials, power series, algebraic numbers, etc., and a lot of
- transcendental functions.
- PARI is also available as a C library to allow for faster computations.")
- (license license:gpl2+)
- (home-page "https://pari.math.u-bordeaux.fr/")))
- (define-public gp2c
- (package
- (name "gp2c")
- (version "0.0.11pl1")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "https://pari.math.u-bordeaux.fr/pub/pari/GP2C/gp2c-"
- version ".tar.gz"))
- (sha256
- (base32
- "1c6f6vmncw032kfzrfyr8bynw6yd3faxpy2285r009fmr0zxfs5s"))))
- (build-system gnu-build-system)
- (native-inputs `(("perl" ,perl)))
- (inputs `(("pari-gp" ,pari-gp)))
- (arguments
- '(#:configure-flags
- (list (string-append "--with-paricfg="
- (assoc-ref %build-inputs "pari-gp")
- "/lib/pari/pari.cfg"))))
- (synopsis "PARI/GP, a computer algebra system for number theory")
- (description
- "PARI/GP is a widely used computer algebra system designed for fast
- computations in number theory (factorisations, algebraic number theory,
- elliptic curves...), but it also contains a large number of other useful
- functions to compute with mathematical entities such as matrices,
- polynomials, power series, algebraic numbers, etc., and a lot of
- transcendental functions.
- PARI is also available as a C library to allow for faster computations.
- GP2C, the GP to C compiler, translates GP scripts to PARI programs.")
- (license license:gpl2)
- (home-page "https://pari.math.u-bordeaux.fr/")))
- (define-public cmh
- (package
- (name "cmh")
- (version "1.0")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "https://gforge.inria.fr/frs/download.php/33497/cmh-"
- version ".tar.gz"))
- (sha256
- (base32
- "1a28xr9bs0igms0ik99x0w8lnb0jyfcmvyi26pbyh9ggcdivd33p"))))
- (build-system gnu-build-system)
- (inputs
- `(("gmp" ,gmp)
- ("mpfr" ,mpfr)
- ("mpc" ,mpc)
- ("mpfrcx" ,mpfrcx)
- ("fplll" ,fplll)
- ("pari-gp" ,pari-gp)))
- (synopsis "Igusa class polynomial computations")
- (description
- "The CMH software computes Igusa (genus 2) class polynomials, which
- parameterize the CM points in the moduli space of 2-dimensional abelian
- varieties, i.e. Jacobians of hyperelliptic curves.
- It can also be used to compute theta constants at arbitrary
- precision.")
- (license license:gpl3+)
- (home-page "http://cmh.gforge.inria.fr/")))
- (define-public giac-xcas
- (package
- (name "giac-xcas")
- (version "1.5.0-37")
- (source (origin
- (method url-fetch)
- ;; "~parisse/giac" is not used because the maintainer regularly
- ;; overwrites the release tarball there, introducing a checksum
- ;; mismatch every time. See
- ;; <https://www-fourier.ujf-grenoble.fr/~parisse/debian/dists/stable/main/source/README>
- (uri (string-append "https://www-fourier.ujf-grenoble.fr/"
- "~parisse/debian/dists/stable/main/"
- "source/giac_" version ".tar.gz"))
- (sha256
- (base32
- "1c6jmswv3ay13n6mjgh9w7nbpdgm5lbwdcmva5sli3vqn4chn3vq"))))
- (build-system gnu-build-system)
- (outputs '("out" "doc")) ;77MiB of documentation
- (arguments
- `(#:modules ((ice-9 ftw)
- (guix build utils)
- (guix build gnu-build-system))
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-bin-cp
- ;; Some Makefiles contain hard-coded "/bin/cp".
- (lambda _
- (substitute* (find-files "doc" "^Makefile")
- (("/bin/cp") (which "cp")))
- #t))
- (add-after 'unpack 'disable-failing-test
- ;; FIXME: Test failing. Not sure why.
- (lambda _
- (substitute* "check/Makefile.in"
- (("chk_fhan11") ""))
- #t))
- (add-after 'install 'install-doc
- ;; Setting --docdir to "doc" output isn't sufficient as
- ;; documentation and examples are scattered throughout the source.
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (doc (assoc-ref outputs "doc"))
- (docdir (string-append doc
- "/share/doc/"
- (string-append ,name "-" ,version))))
- ;; For some reason, the install process moves
- ;; "share/giac/examples" instead of "share/giac/doc" to
- ;; "$(docdir)". Clean up the mess and start over.
- (delete-file-recursively (string-append doc "/share"))
- (mkdir-p docdir)
- (with-directory-excursion out
- (for-each (lambda (f)
- (unless (member f '("." ".."))
- (copy-recursively (string-append "share/giac/" f)
- (string-append docdir "/" f))))
- (scandir "share/giac"))
- (delete-file-recursively "share/giac")))
- #t)))))
- (inputs
- `(("fltk" ,fltk)
- ("gmp" ,gmp)
- ("gsl" ,gsl)
- ("lapack" ,lapack)
- ("libao" ,ao)
- ("libjpeg" ,libjpeg)
- ("libpng" ,libpng)
- ("libx11" ,libx11)
- ("libxinerama" ,libxinerama)
- ("libxft" ,libxft)
- ("libxt" ,libxt)
- ("mesa" ,mesa)
- ("mpfi" ,mpfi)
- ("mpfr" ,mpfr)
- ("ntl" ,ntl)
- ("perl" ,perl)
- ("pari-gp" ,pari-gp)
- ("tcsh" ,tcsh)
- ("texlive" ,texlive-tiny)))
- (native-inputs `(("readline" ,readline)))
- (home-page "https://www-fourier.ujf-grenoble.fr/~parisse/giac.html")
- (synopsis "Computer algebra system")
- (description
- "Giac/Xcas is a computer algebra system. It has a compatibility mode for
- maple, mupad and the TI89. It is available as a standalone program (graphic
- or text interfaces) or as a C++ library.")
- (license license:gpl3+)))
- (define-public flint
- (package
- (name "flint")
- (version "2.5.2")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "http://flintlib.org/flint-"
- version ".tar.gz"))
- (sha256 (base32
- "11syazv1a8rrnac3wj3hnyhhflpqcmq02q8pqk2m6g2k6h0gxwfb"))
- (patches (search-patches "flint-ldconfig.patch"))))
- (build-system gnu-build-system)
- (propagated-inputs
- `(("gmp" ,gmp)
- ("mpfr" ,mpfr))) ; header files from both are included by flint/arith.h
- (arguments
- `(#:parallel-tests? #f ; seems to be necessary on arm
- #:phases
- (modify-phases %standard-phases
- (replace 'configure
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out"))
- (gmp (assoc-ref inputs "gmp"))
- (mpfr (assoc-ref inputs "mpfr")))
- ;; do not pass "--enable-fast-install", which makes the
- ;; homebrew configure process fail
- (invoke "./configure"
- (string-append "--prefix=" out)
- (string-append "--with-gmp=" gmp)
- (string-append "--with-mpfr=" mpfr))
- #t))))))
- (synopsis "Fast library for number theory")
- (description
- "FLINT is a C library for number theory. It supports arithmetic
- with numbers, polynomials, power series and matrices over many base
- rings, including multiprecision integers and rationals, integers
- modulo n, p-adic numbers, finite fields (prime and non-prime order)
- and real and complex numbers (via the Arb extension library).
- Operations that can be performed include conversions, arithmetic,
- GCDs, factoring, solving linear systems, and evaluating special
- functions. In addition, FLINT provides various low-level routines for
- fast arithmetic.")
- (license license:gpl2+)
- (home-page "http://flintlib.org/")))
- (define-public arb
- (package
- (name "arb")
- (version "2.14.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/fredrik-johansson/arb.git")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1ndxg7h4xvccjgp5l9z2f8b66dsff6fhf86bn5n7f75a1ksd7554"))))
- (build-system gnu-build-system)
- (propagated-inputs
- `(("flint" ,flint))) ; flint.h is included by arf.h
- (inputs
- `(("gmp" ,gmp)
- ("mpfr" ,mpfr)))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'configure
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out"))
- (flint (assoc-ref inputs "flint"))
- (gmp (assoc-ref inputs "gmp"))
- (mpfr (assoc-ref inputs "mpfr")))
- ;; do not pass "--enable-fast-install", which makes the
- ;; homebrew configure process fail
- (invoke "./configure"
- (string-append "--prefix=" out)
- (string-append "--with-flint=" flint)
- (string-append "--with-gmp=" gmp)
- (string-append "--with-mpfr=" mpfr))))))))
- (synopsis "Arbitrary precision floating-point ball arithmetic")
- (description
- "Arb is a C library for arbitrary-precision floating-point ball
- arithmetic. It supports efficient high-precision computation with
- polynomials, power series, matrices and special functions over the
- real and complex numbers, with automatic, rigorous error control.")
- (license license:lgpl2.1+)
- (home-page "http://fredrikj.net/arb/")))
- (define-public ntl
- (package
- (name "ntl")
- (version "9.7.0")
- (source (origin
- (method url-fetch)
- (uri (string-append "http://shoup.net/ntl/ntl-"
- version ".tar.gz"))
- (sha256 (base32
- "115frp5flyvw9wghz4zph1b3llmr5nbxk1skgsggckr81fh3gmxq"))))
- (build-system gnu-build-system)
- (native-inputs
- `(("libtool" ,libtool)
- ("perl" ,perl))) ; for configuration
- ;; FIXME: Add optional input gf2x once available; then also add
- ;; configure flag "NTL_GF2X_LIB=on".
- (inputs
- `(("gmp" ,gmp)))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- (chdir "src")
- (system* "./configure"
- (string-append "PREFIX=" (assoc-ref outputs "out"))
- ;; Do not build especially for the build machine.
- "NATIVE=off"
- ;; Also do not tune to the build machine.
- "WIZARD=off"
- "SHARED=on")
- #t)))))
- (synopsis "C++ library for number theory")
- (description
- "NTL is a C++ library providing data structures and algorithms
- for manipulating signed, arbitrary length integers, and for vectors,
- matrices, and polynomials over the integers and over finite fields.")
- (license license:gpl2+)
- (home-page "http://shoup.net/ntl/")))
- (define-public singular
- (package
- (name "singular")
- (version "4.1.1p3")
- (source
- (origin
- (method url-fetch)
- (uri
- (string-append "http://www.mathematik.uni-kl.de/ftp/pub/Math/"
- "Singular/SOURCES/"
- (string-join
- (string-split
- (string-trim-right version #\p
- 0 (1- (string-length version)))
- #\.) "-")
- "/singular-" version ".tar.gz"))
- (sha256 (base32
- "1qqj9bm9pkzm0iyycpvm8x6s79wws3nq60lz25h8x1q61h3426sm"))))
- (build-system gnu-build-system)
- (native-inputs
- `(("doxygen" ,doxygen)
- ("graphviz" ,graphviz)
- ("perl" ,perl)))
- (inputs
- `(("cddlib" ,cddlib)
- ("gmp" ,gmp)
- ("flint" ,flint)
- ("mpfr" ,mpfr)
- ("ntl" ,ntl)
- ("python" ,python-2)
- ("readline" ,readline)))
- (arguments
- `(#:configure-flags
- (list (string-append "--with-ntl="
- (assoc-ref %build-inputs "ntl")))))
- (synopsis "Computer algebra system for polynomial computations")
- (description
- "Singular is a computer algebra system for polynomial computations,
- with special emphasis on commutative and non-commutative algebra, algebraic
- geometry and singularity theory.")
- ;; Singular itself is dual licensed gpl2 or gpl3, but some of the
- ;; libraries with which it links are licensed under lgpl3+, so the
- ;; combined work becomes gpl3. See COPYING in the source code.
- (license license:gpl3)
- (home-page "http://www.singular.uni-kl.de/index.php")))
- (define-public gmp-ecm
- (package
- (name "gmp-ecm")
- (version "7.0.4")
- (source (origin
- (method url-fetch)
- ;; Use the ‘Latest version’ link for a stable URI across releases.
- (uri (string-append "https://gforge.inria.fr/frs/download.php/"
- "latestfile/160/ecm-" version ".tar.gz"))
- (sha256 (base32
- "0hxs24c2m3mh0nq1zz63z3sb7dhy1rilg2s1igwwcb26x3pb7xqc"))))
- (build-system gnu-build-system)
- (inputs
- `(("gmp" ,gmp)))
- (arguments
- `(#:configure-flags '("--enable-shared"
- ;; Disable specific assembly routines, which depend
- ;; on the subarchitecture of the build machine,
- ;; and use gmp instead.
- "--disable-asm-redc")))
- (synopsis "Integer factorization library using the elliptic curve method")
- (description
- "GMP-ECM factors integers using the elliptic curve method (ECM) as well
- as the P-1 and P+1 algorithms. It provides a library and a stand-alone
- binary.")
- ;; Most files are under lgpl3+, but some are under gpl3+ or gpl2+,
- ;; so the combined work is under gpl3+.
- (license license:gpl3+)
- (home-page "http://ecm.gforge.inria.fr/")))
- (define-public bc
- (package
- (name "bc")
- (version "1.07.1")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://gnu/bc/bc-" version ".tar.gz"))
- (sha256
- (base32
- "0amh9ik44jfg66csyvf4zz1l878c4755kjndq9j0270akflgrbb2"))))
- (build-system gnu-build-system)
- (native-inputs
- `(("ed" ,ed)
- ("flex" ,flex)
- ("texinfo" ,texinfo)))
- (arguments
- '(#:configure-flags
- (list "--with-readline")))
- (home-page "https://www.gnu.org/software/bc/")
- (synopsis "Arbitrary precision numeric processing language")
- (description
- "bc is an arbitrary precision numeric processing language. It includes
- an interactive environment for evaluating mathematical statements. Its
- syntax is similar to that of C, so basic usage is familiar. It also includes
- \"dc\", a reverse-polish calculator.")
- (license license:gpl2+)))
- ;; The original kiss-fft does not have a complete build system and does not
- ;; build any shared libraries. This is a fork used by Extempore.
- (define-public kiss-fft-for-extempore
- (package
- (name "kiss-fft-for-extempore")
- (version "1.3.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/extemporelang/kiss_fft.git")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0jasbmqy4wkqrqx3w64s1dfmj34875xmsl72mb26aa4hpyn14bi2"))))
- (build-system cmake-build-system)
- (arguments `(#:tests? #f)) ; no tests included
- ;; Extempore refuses to build on architectures other than x86_64
- (supported-systems '("x86_64-linux"))
- (home-page "https://github.com/extemporelang/kiss_fft")
- (synopsis "Mixed-radix Fast Fourier Transform")
- (description
- "Kiss FFT attempts to be a reasonably efficient, moderately useful FFT
- that can use fixed or floating data types and can easily be incorporated into
- a C program.")
- (license license:bsd-3)))
- (define-public fftw
- (package
- (name "fftw")
- (version "3.3.8")
- (source (origin
- (method url-fetch)
- (uri (string-append "ftp://ftp.fftw.org/pub/fftw/fftw-"
- version".tar.gz"))
- (sha256
- (base32
- "00z3k8fq561wq2khssqg0kallk0504dzlx989x3vvicjdqpjc4v1"))))
- (build-system gnu-build-system)
- (arguments
- `(#:configure-flags
- '("--enable-shared" "--enable-openmp" "--enable-threads"
- ,@(let ((system (or (%current-target-system) (%current-system))))
- ;; Enable SIMD extensions for codelets. See details at:
- ;; <http://fftw.org/fftw3_doc/Installation-on-Unix.html>.
- (cond
- ((string-prefix? "x86_64" system)
- '("--enable-sse2" "--enable-avx" "--enable-avx2"
- "--enable-avx512" "--enable-avx-128-fma"))
- ((string-prefix? "i686" system)
- '("--enable-sse2"))
- ((string-prefix? "aarch64" system)
- ;; Note that fftw supports NEON on 32-bit ARM only when
- ;; compiled for single-precision.
- '("--enable-neon"))
- (else
- '())))
- ;; By default '-mtune=native' is used. However, that may cause the
- ;; use of ISA extensions (e.g. AVX) that are not necessarily
- ;; available on the user's machine when that package is built on a
- ;; different machine.
- "ax_cv_c_flags__mtune_native=no")))
- (native-inputs `(("perl" ,perl)))
- (home-page "http://fftw.org")
- (synopsis "Computing the discrete Fourier transform")
- (description
- "FFTW is a C subroutine library for computing the discrete Fourier
- transform (DFT) in one or more dimensions, of arbitrary input size, and of
- both real and complex data (as well as of even/odd data---i.e. the discrete
- cosine/ sine transforms or DCT/DST).")
- (license license:gpl2+)))
- (define-public fftwf
- (package (inherit fftw)
- (name "fftwf")
- (arguments
- (substitute-keyword-arguments (package-arguments fftw)
- ((#:configure-flags fftw-configure-flags)
- `(cons* "--enable-single"
- ,@(if (string-prefix? "arm" (or (%current-target-system)
- (%current-system)))
- ;; fftw supports NEON on 32-bit ARM only when compiled
- ;; for single-precision, so add it here.
- '("--enable-neon")
- '())
- ,fftw-configure-flags))))
- (description
- (string-append (package-description fftw)
- " Single-precision version."))))
- (define-public fftw-openmpi
- (package (inherit fftw)
- (name "fftw-openmpi")
- (inputs
- `(("openmpi" ,openmpi)
- ,@(package-inputs fftw)))
- (arguments
- (substitute-keyword-arguments (package-arguments fftw)
- ((#:configure-flags cf)
- `(cons "--enable-mpi" ,cf))
- ((#:phases phases '%standard-phases)
- `(modify-phases ,phases
- (add-before 'check 'mpi-setup
- ,%openmpi-setup)))))
- (description
- (string-append (package-description fftw)
- " With OpenMPI parallelism support."))))
- (define-public java-la4j
- (package
- (name "java-la4j")
- (version "0.6.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/vkostyukov/la4j.git")
- (commit version)))
- (file-name (string-append name "-" version "-checkout"))
- (sha256
- (base32
- "1qir8dr978cfvz9k12m2kbdwpyf6cqdf1d0ilb7lnkhbgq5i53w3"))))
- (build-system ant-build-system)
- (arguments
- `(#:jar-name "la4j.jar"
- #:jdk ,icedtea-8
- #:test-exclude (list "**/Abstract*.java"
- "**/MatrixTest.java"
- "**/DenseMatrixTest.java"
- "**/SparseMatrixTest.java"
- "**/VectorTest.java"
- "**/SparseVectorTest.java"
- "**/DenseVectorTest.java")))
- (native-inputs
- `(("java-junit" ,java-junit)
- ("java-hamcrest-core" ,java-hamcrest-core)))
- (home-page "http://la4j.org/")
- (synopsis "Java library that provides Linear Algebra primitives and algorithms")
- (description "The la4j library is a Java library that provides Linear
- Algebra primitives (matrices and vectors) and algorithms. The key features of
- the la4j library are:
- @itemize
- @item No dependencies and tiny size
- @item Fluent object-oriented/functional API
- @item Sparse (CRS, CCS) and dense (1D/2D arrays) matrices
- @item Linear systems solving (Gaussian, Jacobi, Zeidel, Square Root, Sweep and other)
- @item Matrices decomposition (Eigenvalues/Eigenvectors, SVD, QR, LU, Cholesky and other)
- @item MatrixMarket/CSV IO formats support for matrices and vectors
- @end itemize\n")
- (license license:asl2.0)))
- (define-public java-jlargearrays
- (package
- (name "java-jlargearrays")
- (version "1.6")
- (source (origin
- (method url-fetch)
- (uri (string-append "http://search.maven.org/remotecontent?"
- "filepath=pl/edu/icm/JLargeArrays/"
- version "/JLargeArrays-" version
- "-sources.jar"))
- (file-name (string-append name "-" version ".jar"))
- (sha256
- (base32
- "0v05iphpxbjnd7f4jf1rlqq3m8hslhcm0imdbsgxr20pi3xkaf2a"))))
- (build-system ant-build-system)
- (arguments
- `(#:jar-name "jlargearrays.jar"
- #:tests? #f ; tests are not included in the release archive
- #:jdk ,icedtea-8))
- (propagated-inputs
- `(("java-commons-math3" ,java-commons-math3)))
- (home-page "https://gitlab.com/ICM-VisLab/JLargeArrays")
- (synopsis "Library of one-dimensional arrays that can store up to 263 elements")
- (description "JLargeArrays is a Java library of one-dimensional arrays
- that can store up to 263 elements.")
- (license license:bsd-2)))
- (define-public java-jtransforms
- (package
- (name "java-jtransforms")
- (version "3.1")
- (source (origin
- (method url-fetch)
- (uri (string-append "http://search.maven.org/remotecontent?"
- "filepath=com/github/wendykierp/JTransforms/"
- version "/JTransforms-" version "-sources.jar"))
- (sha256
- (base32
- "1haw5m8shv5srgcpwkl853dz8bv6h90bzlhcps6mdpb4cixjirsg"))))
- (build-system ant-build-system)
- (arguments
- `(#:jar-name "jtransforms.jar"
- #:tests? #f ; tests are not included in the release archive
- #:jdk ,icedtea-8))
- (propagated-inputs
- `(("java-commons-math3" ,java-commons-math3)
- ("java-jlargearrays" ,java-jlargearrays)))
- (home-page "https://github.com/wendykierp/JTransforms")
- (synopsis "Multithreaded FFT library written in pure Java")
- (description "JTransforms is a multithreaded FFT library written in pure
- Java. Currently, four types of transforms are available: @dfn{Discrete
- Fourier Transform} (DFT), @dfn{Discrete Cosine Transform} (DCT), @dfn{Discrete
- Sine Transform} (DST) and @dfn{Discrete Hartley Transform} (DHT).")
- (license license:bsd-2)))
- (define-public eigen
- (package
- (name "eigen")
- (version "3.3.5")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://bitbucket.org/eigen/eigen/get/"
- version ".tar.bz2"))
- (sha256
- (base32
- "1qh3yrwn78ms5yhwbpl5wvblk4gbz02cacdygxylr7i9xbrvylkk"))
- (file-name (string-append name "-" version ".tar.bz2"))
- (modules '((guix build utils)))
- (snippet
- ;; There are 3 test failures in the "unsupported" directory,
- ;; but maintainers say it's a known issue and it's unsupported
- ;; anyway, so just skip them.
- '(begin
- (substitute* "unsupported/CMakeLists.txt"
- (("add_subdirectory\\(test.*")
- "# Do not build the tests for unsupported features.\n"))
- #t))))
- (build-system cmake-build-system)
- (arguments
- '(;; Turn off debugging symbols to save space.
- #:build-type "Release"
- #:phases (modify-phases %standard-phases
- (replace 'check
- (lambda _
- (let* ((cores (parallel-job-count))
- (dash-j (format #f "-j~a" cores)))
- (setenv "EIGEN_SEED" "1") ;for reproducibility
- ;; First build the tests, in parallel. See
- ;; <http://eigen.tuxfamily.org/index.php?title=Tests>.
- (invoke "make" "buildtests" dash-j)
- ;; Then run 'CTest' with -V so we get more
- ;; details upon failure.
- (invoke "ctest" "-V" dash-j)))))))
- (home-page "https://eigen.tuxfamily.org")
- (synopsis "C++ template library for linear algebra")
- (description
- "Eigen is a C++ template library for linear algebra: matrices, vectors,
- numerical solvers, and related algorithms. It provides an elegant API based
- on \"expression templates\". It is versatile: it supports all matrix sizes,
- all standard numeric types, various matrix decompositions and geometry
- features, and more.")
- ;; Most of the code is MPLv2, with a few files under LGPLv2.1+ or BSD-3.
- ;; See 'COPYING.README' for details.
- (license license:mpl2.0)))
- (define-public xtensor
- (package
- (name "xtensor")
- (version "0.17.1")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/QuantStack/xtensor.git")
- (commit version)))
- (sha256
- (base32
- "0w40v5lp0hp8ihf8nnvak373sb5xx0768pxgiqh3nzn57wf8px4r"))
- (file-name (git-file-name name version))))
- (build-system cmake-build-system)
- (native-inputs
- `(("googletest" ,googletest)
- ("xtl" ,xtl)))
- (arguments
- `(#:configure-flags
- '("-DBUILD_TESTS=ON")
- #:test-target "xtest"))
- (home-page "http://quantstack.net/xtensor")
- (synopsis "C++ tensors with broadcasting and lazy computing")
- (description "xtensor is a C++ library meant for numerical analysis with
- multi-dimensional array expressions.
- xtensor provides:
- @itemize
- @item an extensible expression system enabling lazy broadcasting.
- @item an API following the idioms of the C++ standard library.
- @item tools to manipulate array expressions and build upon xtensor.
- @end itemize")
- (license license:bsd-3)))
- (define-public gap
- (package
- (name "gap")
- (version "4.10.0")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "https://www.gap-system.org/pub/gap/gap-"
- (version-major+minor version)
- "/tar.bz2/gap-"
- version
- ".tar.bz2"))
- (sha256
- (base32
- "1dmb8v4p7j1nnf7sx8sg54b49yln36bi9acwp7w1d3a1nxj17ird"))
- (modules '((guix build utils) (ice-9 ftw) (srfi srfi-1)))
- (snippet
- '(begin
- ;; Delete the external gmp and zlib libraries
- ;; and a subdirectory not needed for our build.
- (for-each delete-file-recursively
- '("extern" "hpcgap"))
- ;; Delete a failing test.
- ;; FIXME: This might be fixed in the next release, see
- ;; https://github.com/gap-system/gap/issues/3292
- (delete-file "tst/testinstall/dir.tst")
- ;; Delete all packages except for a fixed list.
- (with-directory-excursion "pkg"
- (for-each delete-file-recursively
- (lset-difference string=? (scandir ".")
- '("." ".."
- ;; Necessary packages.
- "GAPDoc-1.6.2"
- "primgrp-3.3.2"
- "SmallGrp-1.3" ; artistic2.0
- "transgrp" ; artistic2.0 for data,
- ; gpl2 or gpl3 for code
- ;; Recommanded package.
- "io-4.5.4" ; gpl3+
- ;; Optional packages, searched for at start,
- ;; and their depedencies.
- "alnuth-3.1.0"
- "AutoDoc-2018.09.20"
- "autpgrp-1.10"
- "crisp-1.4.4" ; bsd-2
- ; "ctbllib" ; no explicit license, drop
- "FactInt-1.6.2"
- "fga"
- "irredsol-1.4" ; bsd-2
- "laguna-3.9.0"
- "polenta-1.3.8"
- "polycyclic-2.14"
- "radiroot-2.8"
- "resclasses-4.7.1"
- "sophus-1.24"
- ; "tomlib-1.2.7" ; no explicit license, drop
- "utils-0.59"))))
- #t))))
- (build-system gnu-build-system)
- (inputs
- `(("gmp" ,gmp)
- ("zlib" ,zlib)))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'build 'build-packages
- ;; Compile all packages that have not been deleted by the
- ;; code snippet above.
- (lambda _
- (setenv "CONFIG_SHELL" (which "bash"))
- (with-directory-excursion "pkg"
- (invoke "../bin/BuildPackages.sh")
- #t)))
- (add-after 'build-packages 'build-doc
- ;; The documentation is bundled, but we create it from source.
- (lambda _
- (with-directory-excursion "doc"
- (invoke "./make_doc"))
- #t))
- (replace 'check
- (lambda _
- ;; "make check" is expected to appear in gap-4.10.1
- (invoke "./gap" "tst/testinstall.g")
- #t))
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (bin (string-append out "/bin"))
- (prog (string-append bin "/gap"))
- (prog-real (string-append bin "/.gap-real"))
- (share (string-append out "/share/gap"))
- (include (string-append out "/include/gap")))
- ;; Install only the gap binary; the gac compiler is left
- ;; for maybe later. "Wrap" it in a shell script that calls
- ;; the binary with the correct parameter.
- (mkdir-p bin)
- (copy-file "gap" prog-real)
- (call-with-output-file prog
- (lambda (port)
- (format port
- "#!~a~%exec ~a -l ~a \"$@\"~%"
- (which "bash")
- prog-real
- share)))
- (chmod prog #o755)
- ;; Install the headers and the library, which are needed by
- ;; Sage. The Makefile targets are available in gap-4.10.0,
- ;; but planned to be removed in gap-4.10.1.
- (invoke "make" "install-headers")
- (invoke "make" "install-libgap")
- (install-file "gen/config.h" include)
- ;; Install a certain number of files and directories to
- ;; SHARE, where the wrapped shell script expects them.
- ;; Remove information on the build directory from sysinfo.gap.
- (substitute* "sysinfo.gap"
- (("GAP_BIN_DIR=\".*\"") "GAP_BIN_DIR=\"\"")
- (("GAP_LIB_DIR=\".*\"") "GAP_LIB_DIR=\"\"")
- (("GAP_CPPFLAGS=\".*\"") "GAP_CPPFLAGS=\"\""))
- (install-file "sysinfo.gap" share)
- (copy-recursively "grp" (string-append share "/grp"))
- (copy-recursively "pkg" (string-append share "/pkg"))
- ;; The following is not the C library libgap.so, but a
- ;; library of GAP code.
- (copy-recursively "lib" (string-append share "/lib"))
- ;; The gap binary looks for documentation inside SHARE.
- (copy-recursively "doc" (string-append share "/doc")))
- #t)))))
- (home-page "https://www.gap-system.org/")
- (synopsis
- "System for computational group theory")
- (description
- "GAP is a system for computational discrete algebra, with particular
- emphasis on computational group theory. It provides a programming language,
- a library of thousands of functions implementing algebraic algorithms
- written in the GAP language as well as large data libraries of algebraic
- objects.")
- ;; Some packages have different licenses (effectively forcing the
- ;; combined work to be licensed as gpl3+); if this is the case, this
- ;; is mentioned above next to their name.
- ;; Some packages have no license mentioned explicitly; supposedly this
- ;; means that the gpl2+ licence of GAP itself applies, but to be on the
- ;; safe side, we drop them for now.
- (license license:gpl2+)))
|