tmux.nix 974 B

123456789101112131415161718192021222324252627282930313233
  1. { pkgs, ... }:
  2. {
  3. programs.tmux = {
  4. enable = true;
  5. clock24 = true;
  6. customPaneNavigationAndResize = true;
  7. extraConfig = ''
  8. bind-key -T prefix \\ set -g status
  9. bind-key -T prefix C-\; last
  10. set -g mouse on
  11. set -g renumber-windows on
  12. set -g set-titles on
  13. set -g status-left ' #h #[bg=green,fg=black] #S #[default] '
  14. set -g status-right ' #[bg=green,fg=black] %R #[default] %a %d-%b '
  15. set -g status-style bg=terminal,fg=terminal
  16. set -g window-status-format ' #I #W #F '
  17. set -g window-status-style bg=brightblack,fg=white
  18. set -g window-status-current-format ' #I #W #F '
  19. set -g window-status-current-style bg=cyan,fg=black
  20. '';
  21. extraConfigBeforePlugins = ''
  22. set -g @emulate-scroll-for-no-mouse-alternate-buffer on
  23. '';
  24. historyLimit = 10000;
  25. keyMode = "vi";
  26. plugins = with pkgs.tmuxPlugins; [
  27. better-mouse-mode
  28. ];
  29. terminal = "tmux-256color";
  30. };
  31. }