home.nix 752 B

12345678910111213141516171819202122232425
  1. { config, lib, inputs, ... }: {
  2. home-manager = {
  3. sharedModules = with lib; with inputs.self.modules.home;
  4. mkForce (builtins.concatLists [
  5. [({ lib, ... }: {
  6. fonts.fontconfig.enable = false;
  7. home.activation.zshrc = lib.hm.dag.entryAfter [ "writeBoundary" ] ''
  8. if [[ ! -e $HOME/.zshrc ]]; then
  9. $DRY_RUN_CMD touch $HOME/.zshrc
  10. fi
  11. '';
  12. home.stateVersion = config.system.stateVersion;
  13. }) git ]
  14. (optionals (config.roles.desktop != null) [
  15. mpv terminals xdg xresources
  16. ])
  17. (optionals (config.roles.desktop == "gnome") [
  18. dconf gtk
  19. ])
  20. ]);
  21. useGlobalPkgs = true;
  22. useUserPackages = true;
  23. };
  24. }