boot.nix 654 B

123456789101112131415161718192021222324
  1. { config, lib, pkgs, ... }:
  2. with lib;
  3. {
  4. boot = {
  5. consoleLogLevel = mkDefault 0;
  6. initrd = {
  7. systemd.enable = mkIf config.boot.plymouth.enable true;
  8. verbose = mkDefault false;
  9. };
  10. kernelPackages = mkDefault pkgs.linuxPackages_6_6;
  11. kernelParams = [ "boot.shell_on_fail" "quiet" ];
  12. loader = {
  13. efi.canTouchEfiVariables = mkDefault false;
  14. systemd-boot.configurationLimit = mkDefault 100;
  15. timeout = mkDefault 2;
  16. };
  17. plymouth = {
  18. enable = mkDefault false;
  19. font = mkDefault "${pkgs.cantarell-fonts}/share/fonts/cantarell/Cantarell-VF.otf";
  20. };
  21. tmp.useTmpfs = mkDefault true;
  22. };
  23. }