1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556 |
- # Do not modify this file! It was generated by ‘nixos-generate-config’
- # and may be overwritten by future invocations. Please make changes
- # to /etc/nixos/configuration.nix instead.
- { config, lib, modulesPath, ... }:
- {
- imports =
- [ (modulesPath + "/installer/scan/not-detected.nix")
- ];
- boot.initrd.availableKernelModules = [ "xhci_pci" "ahci" "nvme" "usb_storage" "usbhid" "sd_mod" ];
- boot.initrd.kernelModules = [ ];
- boot.kernelModules = [ "kvm-amd" ];
- boot.extraModulePackages = [ ];
- fileSystems."/" =
- { device = "none";
- fsType = "tmpfs";
- };
- fileSystems."/system" =
- { device = "/dev/disk/by-uuid/4ea53649-748c-4229-aa63-f48e46cf5e5c";
- fsType = "btrfs";
- options = [ "subvol=/" ];
- };
- fileSystems."/nix" =
- { device = "/dev/disk/by-uuid/4ea53649-748c-4229-aa63-f48e46cf5e5c";
- fsType = "btrfs";
- options = [ "subvol=/nix" ];
- };
- fileSystems."/home" =
- { device = "/dev/disk/by-uuid/4ea53649-748c-4229-aa63-f48e46cf5e5c";
- fsType = "btrfs";
- options = [ "subvol=/home" ];
- };
- fileSystems."/boot" =
- { device = "/dev/disk/by-uuid/0911-F9C8";
- fsType = "vfat";
- };
- swapDevices = [ ];
- # Enables DHCP on each ethernet and wireless interface. In case of scripted networking
- # (the default) this is the recommended approach. When using systemd-networkd it's
- # still possible to use this option, but it's recommended to use it in conjunction
- # with explicit per-interface declarations with `networking.interfaces.<interface>.useDHCP`.
- networking.useDHCP = lib.mkDefault true;
- # networking.interfaces.enp37s0.useDHCP = lib.mkDefault true;
- nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
- hardware.cpu.amd.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
- }
|