hardware-configuration.nix 1.4 KB

123456789101112131415161718192021222324252627282930313233343536373839
  1. # Do not modify this file! It was generated by ‘nixos-generate-config’
  2. # and may be overwritten by future invocations. Please make changes
  3. # to /etc/nixos/configuration.nix instead.
  4. { config, lib, modulesPath, ... }:
  5. {
  6. imports =
  7. [ (modulesPath + "/installer/scan/not-detected.nix")
  8. ];
  9. boot.initrd.availableKernelModules = [ "xhci_pci" "ahci" "sd_mod" "sdhci_pci" ];
  10. boot.initrd.kernelModules = [ ];
  11. boot.kernelModules = [ "kvm-intel" ];
  12. boot.extraModulePackages = [ ];
  13. fileSystems."/" =
  14. { device = "/dev/disk/by-uuid/25621346-6954-4c08-ab83-8ded6dbe6ea3";
  15. fsType = "ext4";
  16. };
  17. fileSystems."/boot" =
  18. { device = "/dev/disk/by-uuid/3518-2790";
  19. fsType = "vfat";
  20. };
  21. swapDevices = [ ];
  22. # Enables DHCP on each ethernet and wireless interface. In case of scripted networking
  23. # (the default) this is the recommended approach. When using systemd-networkd it's
  24. # still possible to use this option, but it's recommended to use it in conjunction
  25. # with explicit per-interface declarations with `networking.interfaces.<interface>.useDHCP`.
  26. networking.useDHCP = lib.mkDefault true;
  27. # networking.interfaces.wlo1.useDHCP = lib.mkDefault true;
  28. nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
  29. powerManagement.cpuFreqGovernor = lib.mkDefault "powersave";
  30. hardware.cpu.intel.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
  31. }