hardware-configuration.nix 1.8 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556
  1. # Do not modify this file! It was generated by ‘nixos-generate-config’
  2. # and may be overwritten by future invocations. Please make changes
  3. # to /etc/nixos/configuration.nix instead.
  4. { config, lib, modulesPath, ... }:
  5. {
  6. imports =
  7. [ (modulesPath + "/installer/scan/not-detected.nix")
  8. ];
  9. boot.initrd.availableKernelModules = [ "xhci_pci" "ahci" "nvme" "usb_storage" "usbhid" "sd_mod" ];
  10. boot.initrd.kernelModules = [ ];
  11. boot.kernelModules = [ "kvm-amd" ];
  12. boot.extraModulePackages = [ ];
  13. fileSystems."/" =
  14. { device = "none";
  15. fsType = "tmpfs";
  16. };
  17. fileSystems."/system" =
  18. { device = "/dev/disk/by-uuid/4ea53649-748c-4229-aa63-f48e46cf5e5c";
  19. fsType = "btrfs";
  20. options = [ "subvol=/" ];
  21. };
  22. fileSystems."/nix" =
  23. { device = "/dev/disk/by-uuid/4ea53649-748c-4229-aa63-f48e46cf5e5c";
  24. fsType = "btrfs";
  25. options = [ "subvol=/nix" ];
  26. };
  27. fileSystems."/home" =
  28. { device = "/dev/disk/by-uuid/4ea53649-748c-4229-aa63-f48e46cf5e5c";
  29. fsType = "btrfs";
  30. options = [ "subvol=/home" ];
  31. };
  32. fileSystems."/boot" =
  33. { device = "/dev/disk/by-uuid/0911-F9C8";
  34. fsType = "vfat";
  35. };
  36. swapDevices = [ ];
  37. # Enables DHCP on each ethernet and wireless interface. In case of scripted networking
  38. # (the default) this is the recommended approach. When using systemd-networkd it's
  39. # still possible to use this option, but it's recommended to use it in conjunction
  40. # with explicit per-interface declarations with `networking.interfaces.<interface>.useDHCP`.
  41. networking.useDHCP = lib.mkDefault true;
  42. # networking.interfaces.enp37s0.useDHCP = lib.mkDefault true;
  43. nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
  44. hardware.cpu.amd.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
  45. }