acpi-stuff-9999.ebuild 700 B

123456789101112131415161718192021222324252627282930313233
  1. # Copyright 1999-2023 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. DESCRIPTION="Few modules for ACPI debugging"
  5. HOMEPAGE="https://github.com/Lekensteyn/acpi-stuff"
  6. inherit linux-mod
  7. if [[ ${PV} =~ "9999" ]]; then
  8. inherit git-r3
  9. EGIT_REPO_URI="https://github.com/Lekensteyn/${PN}.git"
  10. else
  11. SRC_URI="https://github.com/downloads/Lekensteyn/${PN}/${P}.tar.gz"
  12. KEYWORDS="~amd64 ~x86"
  13. fi
  14. SLOT="0"
  15. LICENSE="GPL-2"
  16. DEPEND="
  17. virtual/linux-sources
  18. sys-kernel/linux-headers
  19. "
  20. MODULE_NAMES="acpi_dump_info(kernel/drivers/acpi:${S}/acpi_dump_info) pcidev(kernel/drivers/acpi:${S}/pcidev)"
  21. pkg_setup() {
  22. linux-mod_pkg_setup
  23. BUILD_TARGETS="default"
  24. }