uboot-orangepi-sources-2020.04.ebuild 567 B

123456789101112131415161718192021222324252627282930313233
  1. # Copyright 2022 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit git-r3 toolchain-funcs
  5. DESCRIPTION="U-Boot for xunlong orangepi devices"
  6. HOMEPAGE="https://github.com/orangepi-xunlong/u-boot-orangepi"
  7. EGIT_REPO_URI="https://github.com/orangepi-xunlong/u-boot-orangepi"
  8. EGIT_BRANCH="v${PV}"
  9. LICENSE="MIT GPL-2"
  10. SLOT="0"
  11. KEYWORDS="arm arm64"
  12. DEPEND=""
  13. RDEPEND="${DEPEND}"
  14. BDEPEND="
  15. sys-devel/bc
  16. "
  17. src_compile() {
  18. :;
  19. }
  20. src_install() {
  21. dodir /usr/src/
  22. cp -R "${S}/" "${D}/usr/src/" || die "Install failed!"
  23. }