arm-trusted-firmware-9999.ebuild 723 B

12345678910111213141516171819202122232425262728293031
  1. # Copyright 2022 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. DESCRIPTION="Reference secure world boot and runtime firmware complying with the relevant Arm specifications"
  5. HOMEPAGE="https://www.trustedfirmware.org"
  6. if [[ ${PV} = *9999* ]]; then
  7. inherit git-r3
  8. EGIT_REPO_URI="https://github.com/ARM-software/${PN}"
  9. EGIT_BRANCH="master"
  10. KEYWORDS=""
  11. else
  12. SRC_URI="https://github.com/ARM-software/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz "
  13. KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc64 ~riscv ~sparc ~x86"
  14. fi
  15. LICENSE="BSD"
  16. SLOT="0"
  17. RESTRICT="mirror"
  18. src_compile() {
  19. :;
  20. }
  21. src_install() {
  22. dodir /usr/src/
  23. cp -R "${S}/" "${D}/usr/src/" || die "Install failed!"
  24. }