eoip-ctl-1.0.1.ebuild 692 B

1234567891011121314151617181920212223242526272829303132
  1. # Copyright 1999-2023 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit toolchain-funcs
  5. DESCRIPTION="Kernel mode EOIP (Ethernet Over IP) tunnel management utility."
  6. HOMEPAGE="https://github.com/ndmsystems/eoip-ctl/blob/1.0-1/README.md"
  7. SRC_URI="https://github.com/ndmsystems/eoip-ctl/archive/refs/heads/master.tar.gz -> ${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. IUSE=""
  11. KEYWORDS="~amd64 ~arm ~x86 ~mips"
  12. RESTRICT="mirror"
  13. S="${WORKDIR}/${PN}-master"
  14. src_compile() {
  15. emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
  16. }
  17. src_install() {
  18. dosbin "${PN}"
  19. }
  20. pkg_postinst() {
  21. elog "Userland tunnel management utility for \"eoip.ko\" kernel module"
  22. }