meshroom-2021.1.0.ebuild 1.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960
  1. # Copyright 1999-2020 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="7"
  4. PYTHON_COMPAT=( python3_{7..9} )
  5. inherit distutils-r1
  6. DESCRIPTION="3D Reconstruction Software AliceVision Photogrammetric Computer Vision framework"
  7. HOMEPAGE="http://alicevision.github.io"
  8. SRC_URI="https://github.com/alicevision/meshroom/archive/v$PV.tar.gz -> $P.tar.gz
  9. https://gitlab.com/alicevision/trainedVocabularyTreeData/-/raw/master/vlfeat_K80L3.SIFT.tree
  10. "
  11. IUSE="alembic qtoiio qtalicevision"
  12. LICENSE=MPL-2.0
  13. SLOT=0
  14. KEYWORDS=~amd64
  15. RESTRICT="test mirror"
  16. RDEPEND=">=dev-python/psutil-5.6.3[${PYTHON_USEDEP}]
  17. >=dev-python/pyside2-5.13.0[qml,quick,charts,${PYTHON_USEDEP}]
  18. >=dev-python/markdown-2.6.11[${PYTHON_USEDEP}]
  19. >=dev-python/requests-2.22.0[${PYTHON_USEDEP}]
  20. >=media-libs/alicevision-2.4.0[alembic?]
  21. dev-python/enum34
  22. qtoiio? ( =dev-qt/qtoiio-${PV} )
  23. qtalicevision? ( =dev-qt/qtalicevision-${PV} )
  24. dev-python/cx_Freeze[${PYTHON_USEDEP}]"
  25. DEPEND="${RDEPEND}
  26. dev-python/setuptools[${PYTHON_USEDEP}]
  27. "
  28. src_prepare() {
  29. # Change the lib install path
  30. #sed -i "s|/usr/lib|${EPREFIX}/usr/${get_libdir}|g" setup.py || die
  31. default
  32. }
  33. #src_configure() {
  34. # Ensure that 'python3' is in PATH. #765118
  35. # python_setup
  36. # CMAKE_BUILD_TYPE=Release
  37. # mycmakeargs=(
  38. # -DQT_DIR=${EPREFIX}/usr/$(get_libdir)/qt5
  39. #-DALICEVISION_ROOT=
  40. # -DMR_BUILD_QTOIIO=$(usex qtoiio)
  41. # -DMR_BUILD_QMLALEMBIC=NO #$(usex alembic)
  42. # -DMR_BUILD_QTALICEVISION=$(usex qtalicevision)
  43. # )
  44. # cmake_src_configure
  45. #}