123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120 |
- # Copyright 1999-2024 Gentoo Authors
- # Distributed under the terms of the GNU General Public License v2
- EAPI=8
- inherit fcaps meson optfeature
- DESCRIPTION="SwayFX: Sway, but with eye candy!"
- HOMEPAGE="https://github.com/WillPower3309/swayfx"
- if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/WillPower3309/swayfx"
- else
- MY_PV=${PV/_rc/-rc}
- SRC_URI="https://github.com/WillPower3309/swayfx/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm64 ~arm ~loong ~ppc64 ~riscv ~x86"
- S="${WORKDIR}/${PN}-${MY_PV}"
- fi
- LICENSE="MIT"
- SLOT="0"
- IUSE="zsh-completion bash-completion fish-completion grimshot +man +swaybar +swaynag tray wallpapers X"
- REQUIRED_USE="tray? ( swaybar )"
- DEPEND="
- >=dev-libs/json-c-0.13:0=
- >=dev-libs/libinput-1.21.0:0=
- virtual/libudev
- sys-auth/seatd:=
- dev-libs/libpcre2
- >=dev-libs/wayland-1.20.0
- gui-libs/scenefx
- x11-libs/cairo
- >=x11-libs/libxkbcommon-1.5.0:0=
- x11-libs/pango
- x11-libs/pixman
- media-libs/mesa[gles2,libglvnd(+)]
- swaybar? ( x11-libs/gdk-pixbuf:2 )
- tray? ( || (
- sys-apps/systemd
- sys-auth/elogind
- sys-libs/basu
- ) )
- wallpapers? ( gui-apps/swaybg[gdk-pixbuf(+)] )
- X? (
- x11-libs/libxcb:0=
- x11-libs/xcb-util-wm
- )
- "
- RDEPEND="
- x11-misc/xkeyboard-config
- grimshot? (
- app-misc/jq
- gui-apps/grim
- gui-apps/slurp
- gui-apps/wl-clipboard
- x11-libs/libnotify
- )
- !!gui-wm/sway
- ${DEPEND}
- "
- BDEPEND="
- >=dev-libs/wayland-protocols-1.24
- >=dev-build/meson-0.60.0
- virtual/pkgconfig
- "
- if [[ ${PV} == 9999 ]]; then
- BDEPEND+="man? ( ~app-text/scdoc-9999 )"
- else
- BDEPEND+="man? ( >=app-text/scdoc-1.9.3 )"
- fi
- FILECAPS=(
- cap_sys_nice usr/bin/sway # bug 919298
- )
- RESTRICT="mirror"
- src_configure() {
- local emesonargs=(
- $(meson_feature man man-pages)
- $(meson_feature tray)
- $(meson_feature X xwayland)
- $(meson_feature swaybar gdk-pixbuf)
- $(meson_use swaynag)
- $(meson_use swaybar)
- $(meson_use wallpapers default-wallpaper)
- $(meson_use zsh-completion zsh-completions)
- $(meson_use bash-completion bash-completions)
- $(meson_use fish-completion fish-completions)
- )
- meson_src_configure
- }
- src_install() {
- meson_src_install
- if use grimshot; then
- use man && doman contrib/grimshot.1
- dobin contrib/grimshot
- fi
- }
- pkg_postinst() {
- fcaps_pkg_postinst
- optfeature_header "There are several packages that may be useful with sway:"
- optfeature "wallpaper utility" gui-apps/swaybg
- optfeature "idle management utility" gui-apps/swayidle
- optfeature "simple screen locker" gui-apps/swaylock
- optfeature "lightweight notification daemon" gui-apps/mako
- echo
- einfo "For a list of additional addons and tools usable with sway please"
- einfo "visit the offical wiki at:"
- einfo "https://github.com/swaywm/sway/wiki/Useful-add-ons-for-sway"
- einfo "Please note that some of them might not (yet) available on gentoo"
- }
|