blendage-9999.ebuild 931 B

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051
  1. # Copyright 1999-2022 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit git-r3 flag-o-matic toolchain-funcs
  5. DESCRIPTION="dwl-compatible Wayland window manager"
  6. HOMEPAGE="https://github.com/pmozil/blendage"
  7. EGIT_REPO_URI="https://github.com/pmozil/${PN}.git"
  8. LICENSE="CC0-1.0 GPL-3 MIT"
  9. SLOT="0"
  10. IUSE="X"
  11. RDEPEND="
  12. dev-libs/libinput:=
  13. dev-libs/wayland
  14. =gui-libs/wlroots-9999[X(-)?]
  15. x11-libs/libxkbcommon
  16. X? (
  17. x11-libs/libxcb:=
  18. x11-libs/xcb-util-wm
  19. )
  20. "
  21. DEPEND="${RDEPEND}"
  22. BDEPEND="
  23. dev-libs/wayland-protocols
  24. dev-util/wayland-scanner
  25. virtual/pkgconfig
  26. "
  27. src_configure() {
  28. sed -i "s:/local::g" config.mk || die
  29. sed -i "s:pkg-config:$(tc-getPKG_CONFIG):g" config.mk || die
  30. if use X; then
  31. append-cppflags '-DXWAYLAND'
  32. append-libs '-lxcb' '-lxcb-icccm'
  33. fi
  34. }
  35. src_install() {
  36. default
  37. insinto /usr/share/wayland-sessions
  38. doins "${FILESDIR}"/${PN}.desktop
  39. }