scenefx-9999.ebuild 1.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263
  1. # Copyright 1999-2025 Gentoo Authors
  2. # Distributed under the terms of the GNU Public License v2
  3. EAPI=8
  4. inherit meson
  5. if [[ ${PV} == 9999 ]]; then
  6. inherit git-r3
  7. EGIT_REPO_URI="https://github.com/wlrfx/scenefx"
  8. else
  9. MY_PV=${PV/_rc/-rc}
  10. SRC_URI="https://github.com/wlrfx/scenefx/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
  11. S="${WORKDIR}/${PN}-${MY_PV}"
  12. KEYWORDS="~amd64 ~arm64 ~arm ~loong ~ppc64 ~riscv ~x86"
  13. fi
  14. DESCRIPTION="A replacement for the wlroots scene API with eye-candy effects."
  15. HOMEPAGE="https://github.com/wlrfx/scenefx"
  16. LICENSE="MIT"
  17. SLOT="0"
  18. IUSE="X man examples"
  19. DEPEND="
  20. >=dev-libs/wayland-1.23.0
  21. >=x11-libs/libdrm-2.4.122
  22. media-libs/mesa[egl(+),gles2(+)]
  23. >=x11-libs/pixman-0.42.0
  24. media-libs/libglvnd
  25. x11-libs/libxkbcommon
  26. X? (
  27. x11-libs/libxcb:=
  28. x11-libs/xcb-util-wm
  29. x11-base/xwayland
  30. )
  31. "
  32. # Check this on every update
  33. DEPEND+="
  34. >=gui-libs/wlroots-0.18:=[X?]
  35. <gui-libs/wlroots-0.19:=[X?]
  36. "
  37. RDEPEND="${DEPEND}"
  38. BDEPEND="
  39. >=dev-libs/wayland-protocols-1.35
  40. >=dev-build/meson-0.59.0
  41. dev-util/glslang
  42. app-alternatives/ninja
  43. virtual/pkgconfig
  44. virtual/libc
  45. "
  46. BDEPEND+="man? ( >=app-text/scdoc-1.9.2 )"
  47. RESTRICT="mirror"
  48. src_configure() {
  49. local emesonargs=(
  50. -Drenderers=auto
  51. $(meson_use examples)
  52. )
  53. meson_src_configure
  54. }