pwclient-9999.ebuild 802 B

12345678910111213141516171819202122232425262728293031323334
  1. # Copyright 1999-2023 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. PYTHON_COMPAT=( python3_{10..12} )
  5. DISTUTILS_USE_PEP517=setuptools
  6. inherit distutils-r1
  7. DESCRIPTION="The command-line client for the patchwork patch tracking tool"
  8. HOMEPAGE="https://github.com/getpatchwork/pwclient"
  9. if [[ ${PV} == "9999" ]]; then
  10. inherit git-r3
  11. EGIT_REPO_URI="https://github.com/getpatchwork/${PN}"
  12. else
  13. SRC_URI="https://github.com/getpatchwork/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
  14. KEYWORDS="~amd64 ~x86 ~arm ~arm64"
  15. RESTRICT="mirror "
  16. fi
  17. LICENSE="LGPL-2"
  18. SLOT="0"
  19. IUSE=""
  20. RESTRICT+="!test ( test )"
  21. REQUIRED_USE="${PYTHON_REQUIRED_USE}"
  22. RDEPEND="${PYTHON_DEPS}
  23. dev-python/importlib-metadata[${PYTHON_USEDEP}]
  24. >=dev-python/pbr-5.7.0[${PYTHON_USEDEP}]
  25. "