antonio-1.1.0.ebuild 904 B

1234567891011121314151617181920212223242526272829303132333435
  1. # Copyright 1999-2023 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit font
  5. MY_PN="${PN}Font"
  6. DESCRIPTION="A 'refined' version of the Anton font, a large typeface designed for banners and headlines"
  7. HOMEPAGE="https://github.com/vernnobile/antonioFont"
  8. EGIT_COMMIT="4b3e07ab5647a613931153a09067a785f54b980a"
  9. SRC_URI="https://github.com/vernnobile/${MY_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${MY_PN}-${EGIT_COMMIT}.tar.gz"
  10. IUSE="+otf +ttf"
  11. REQUIRED_USE="|| ( otf ttf )"
  12. LICENSE="|| ( LGPL-2.1 OFL-1.1 )"
  13. SLOT="0"
  14. KEYWORDS="*"
  15. # No binaries, only fonts
  16. RESTRICT="strip binchecks mirror"
  17. S="${WORKDIR}/${MY_PN}-${EGIT_COMMIT}"
  18. DOCS="README.md"
  19. src_install() {
  20. for dir in Bold Light Regular; do
  21. use otf && FONT_S="${S}/${dir}/src/" FONT_SUFFIX="otf" font_src_install
  22. use ttf && FONT_S="${S}/${dir}/src/" FONT_SUFFIX="ttf" font_src_install
  23. done
  24. }