gfxboot-themes-aur-1.0.0.ebuild 669 B

12345678910111213141516171819202122232425262728293031323334
  1. # Copyright 1999-2023 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. DESCRIPTION="Gfxboot themes for Gentoo Linux"
  5. HOMEPAGE="https://www.github.com/anex5"
  6. EGIT_REPO_URI="https://www.github.com/anex5/gfxboot-themes-aur.git"
  7. inherit git-r3
  8. LICENSE="Apache-2.0"
  9. SLOT="0"
  10. KEYWORDS="amd64 x86"
  11. IUSE=""
  12. BDEPEND="media-gfx/gfxboot
  13. dev-lang/perl
  14. dev-vcs/git"
  15. RDEPEND="${DEPEND}"
  16. src_compile() {
  17. chmod 0755 po/bin/{rm_text,po2txt,fixpot,change_text,add_text} || die
  18. emake -j1
  19. }
  20. src_install() {
  21. dodir /usr/share/themes/gfxboot-themes-aur
  22. insinto /usr/share/themes/gfxboot-themes-aur
  23. doins -r install/bootlogo
  24. }